Junos OS에서 지원하는 SNMP 트랩
네트워크 디바이스 및 시스템은 표준 SNMP 트랩과 엔터프라이즈별 트랩을 지원합니다.
기능 탐색기를 사용하여 특정 기능에 대한 플랫폼 및 릴리스 지원을 확인하십시오.
플랫폼과 관련된 참고 사항은 플랫폼별 SNMP 트랩 동작 섹션을 검토합니다.
SNMP 트랩은 QFX 시리즈 독립형 스위치, QFX 시리즈 Virtual Chassis 및 QFabric 시스템에서 지원됩니다
QFX 시리즈 독립형 스위치 및 QFX 시리즈 Virtual Chassis에서 지원되는 SNMP 트랩
QFX 시리즈 독립형 스위치와 QFX 시리즈 Virtual Chassis는 SNMPv1 및 SNMPv2 트랩을 지원합니다. 자세한 정보는 다음을 참조하십시오.
SNMPv1 트랩
QFX 시리즈 독립형 스위치와 QFX 시리즈 Virtual Chassis는 표준 SNMPv1 트랩과 주니퍼 네트웍스 엔터프라이즈별 SNMPv1 트랩을 모두 지원합니다. 참조:
트랩은 트랩 범주로 먼저 조직된 다음 트랩 이름으로 구성됩니다. 시스템 로깅 심각도 수준은 해당 수준이 있는 트랩에 대해 나열됩니다. 해당 시스템 로깅 심각도 수준을 갖지 않은 트랩은 짧은 대시(-)로 표시됩니다.
|
정의 위치 |
트랩 이름 |
엔터프라이즈 ID |
일반 트랩 번호 |
특정 트랩 번호 |
시스템 로깅 심각도 수준 |
Syslog 태그 |
|---|---|---|---|---|---|---|
| 링크 알림 | ||||||
|
RFC 1215, SNMP와 함께 사용하기 위한 트랩 정의 규칙 |
링크다운 |
1.3.6.1.4.1.2636 |
2 |
0 |
경고 |
SNMP_ TRAP_ LINK_DOWN |
|
링크업 |
1.3.6.1.4.1.2636 |
3 |
0 |
정보 |
SNMP_TRAP_ LINK_UP |
|
| 원격 운영 알림 | ||||||
|
RFC 2925, 원격 핑, 경로 추적, 조회 작업에 대한 매니지드 객체의 정의 |
pingProbeFailed |
1.3.6.1.2.1.80.0 |
6 |
1 |
정보 |
SNMP_TRAP _PING_ PROBE_ 실패했습니다. |
|
pingTest실패 |
1.3.6.1.2.1.80.0 |
6 |
2 |
정보 |
SNMP_TRAP_ PING_TEST _FAILED |
|
|
pingTest완료됨 |
1.3.6.1.2.1.80.0 |
6 |
3 |
정보 |
SNMP_TRAP_ PING_TEST_ 완료 |
|
|
traceRoutePathChange |
1.3.6.1.2.1.81.0 |
6 |
1 |
정보 |
SNMP_TRAP_ TRACE_ROUTE_ PATH_CHANGE |
|
|
traceRouteTestFailed |
1.3.6.1.2.1.81.0 |
6 |
2 |
정보 |
SNMP_TRAP_ TRACE_ROUTE_ TEST_FAILED |
|
|
traceRouteTestCompleted |
1.3.6.1.2.1.81.0 |
6 |
3 |
정보 |
SNMP_TRAP_ TRACE_ROUTE_ TEST_COMPLETED |
|
| RMON 알람 | ||||||
|
RFC 2819a, RMON MIB |
떨어지는 알람 |
1.3.6.1.2.1.16 |
6 |
2 |
– |
– |
|
상승알람 |
1.3.6.1.2.1.16 |
6 |
1 |
– |
– |
|
| 라우팅 알림 | ||||||
|
BGP 4 MIB |
bgp설립 |
1.3.6.1.2.1.15.7 |
6 |
1 |
– |
– |
|
bgpBackwardTransition |
1.3.6.1.2.1.15.7 |
6 |
2 |
– |
– |
|
|
OSPF 트랩 MIB |
ospfVirtIfStateChange |
1.3.6.1.2.1.14.16.2 |
6 |
1 |
– |
– |
|
ospfNbrStateChange |
1.3.6.1.2.1.14.16.2 |
6 |
2 |
– |
– |
|
|
ospfVirtNbrStateChange |
1.3.6.1.2.1.14.16.2 |
6 |
3 |
– |
– |
|
|
ospfIfConfigError |
1.3.6.1.2.1.14.16.2 |
6 |
4 |
– |
– |
|
|
ospfVirtIfConfigError |
1.3.6.1.2.1.14.16.2 |
6 |
5 |
– |
– |
|
|
ospfIfAuthFailure |
1.3.6.1.2.1.14.16.2 |
6 |
6 |
– |
– |
|
|
ospfVirtIfAuthFailure |
1.3.6.1.2.1.14.16.2 |
6 |
7 |
– |
– |
|
|
ospfIfRxBadPacket |
1.3.6.1.2.1.14.16.2 |
6 |
8 |
– |
– |
|
|
ospfVirtIfRxBadPacket |
1.3.6.1.2.1.14.16.2 |
6 |
9 |
– |
– |
|
|
ospfTx재전송 |
1.3.6.1.2.1.14.16.2 |
6 |
10 |
– |
– |
|
|
ospfVirtIfTx재전송 |
1.3.6.1.2.1.14.16.2 |
6 |
11 |
– |
– |
|
|
ospfMaxAgeLsa |
1.3.6.1.2.1.14.16.2 |
6 |
13 |
– |
– |
|
|
ospfIfState변경 |
1.3.6.1.2.1.14.16.2 |
6 |
16 |
– |
– |
|
| 시작 알림 | ||||||
|
RFC 1215, SNMP와 함께 사용하기 위한 트랩 정의 규칙 |
authenticationFailure |
1.3.6.1.4.1.2636 |
4 |
0 |
주의 사항 |
SNMPD_ TRAP_ GEN_FAILURE |
|
콜드스타트 |
1.3.6.1.4.1.2636 |
0 |
0 |
위험 |
SNMPD_TRAP_ COLD_START |
|
|
웜스타트 |
1.3.6.1.4.1.2636 |
1 |
0 |
오류 |
SNMPD_TRAP_ WARM_START |
|
| VRRP 알림 | ||||||
|
RFC 2787, 가상 라우터 중복 프로토콜에 대한 매니지드 객체의 정의 |
vrrpTrapNewMaster |
1.3.6.1.2.1.68 |
6 |
1 |
경고 |
VRRPD_NEW MASTER_TRAP |
|
vrrpTrapAuthFailure |
1.3.6.1.2.1.68 |
6 |
2 |
경고 |
VRRPD_AUTH_ FAILURE_TRAP |
|
|
정의 위치 |
트랩 이름 |
엔터프라이즈 ID |
일반 트랩 번호 |
특정 트랩 번호 |
시스템 로깅 심각도 수준 |
시스템 로그 태그 |
|---|---|---|---|---|---|---|
| 섀시 알림(알람 조건) | ||||||
|
섀시 MIB (jnx-chassis. mib) |
jnx전원 공급 장치 장애 |
1.3.6.1.4.1.2636.4.1 |
6 |
1 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
jnxFanFailure |
1.3.6.1.4.1.26361 |
6 |
2 |
위험 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx과열 |
11.4.1.2636.4.1 |
6 |
3 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru제거 |
1.3.6.1.4.1.2636.4.1 |
6 |
5 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru삽입 |
1.3.6.1.4.1.2636.4.1 |
6 |
6 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru전원 끄기 |
1.3.6.1.4.1.2636.4.1 |
6 |
7 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFruPowerOn |
1.3.6.1.4.1.2636.4.1 |
6 |
8 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru실패 |
1.3.6.1.4.1.2636.4.1 |
6 |
9 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru오프라인 |
1.3.6.1.4.1.2636.4.1 |
6 |
10 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru온라인 |
1.3.6.1.4.1.2636.4.1 |
6 |
11 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru체크 |
1.3.6.1.4.1.2636.4.1 |
6 |
12 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx전원 공급 장치Ok |
1.3.6.1.4.1.2636.4.2 |
6 |
1 |
위험 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx팬OK |
1.3.6.1.4.1.2636.4.2 |
6 |
2 |
위험 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx온도OK |
1.3.6.1.4.1.2636.4.2 |
6 |
3 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
| 구성 알림 | ||||||
|
구성 관리 MIB (jnx- configmgmt. mib) |
jnxCmCfg변경 |
1.3.6.1.4.1.2636.4.5 |
6 |
1 |
– |
– |
|
jnxCmRescueChange |
1.3.6.1.4.1.2636.4.5 |
6 |
2 |
– |
– |
|
| 원격 작업 | ||||||
|
Ping MIB (jnx-ping.mib) |
jnxPingRtt임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
1 |
– |
– |
|
jnxPingRttStdDev임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
2 |
– |
– |
|
|
jnxPingRttJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
3 |
– |
– |
|
|
jnxPingEgress임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
4 |
– |
– |
|
|
jnxPingEgressStdDev 임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
5 |
– |
– |
|
|
jnxPingEgressJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
6 |
– |
– |
|
|
jnxPingIngressThreshold 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
7 |
– |
– |
|
|
jnxPingIngressStddev임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
8 |
– |
– |
|
|
jnxPingIngressJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9 |
6 |
9 |
– |
– |
|
| RMON 알람 | ||||||
|
RMON MIB (jnx-rmon. mib) |
jnxRmonAlarmGetFailure |
1.3.6.1.4.1.2636.4.3 |
6 |
1 |
– |
– |
|
jnxRmonGetOk |
1.3.6.1.4.1.2636.4.3 |
6 |
2 |
– |
– |
|
SNMPv2 트랩
|
정의 위치 |
트랩 이름 |
SNMP 트랩 OID |
시스템 로깅 심각도 수준 |
Syslog 태그 |
|---|---|---|---|---|
| 링크 알림 | ||||
|
RFC 2863, 인터페이스 그룹 MIB |
링크다운 |
1.3.6.1.6.3.1.1.5.3 |
경고 |
SNMP_TRAP_ LINK_DOWN |
|
링크업 |
1.3.6.1.6.3.1.1.5.4 |
정보 |
SNMP_TRAP_ LINK_UP |
|
| 원격 운영 알림 | ||||
|
RFC 2925, 원격 핑, 경로 추적, 조회 작업에 대한 매니지드 객체의 정의 |
pingProbeFailed |
1.3.6.1.2.1.80.0.1 |
정보 |
SNMP_TRAP_ PING_PROBE_ 실패했습니다. |
|
pingTest실패 |
1.3.6.1.2.1.80.0.2 |
정보 |
SNMP_TRAP_PING_ TEST_FAILED |
|
|
pingTest완료됨 |
1.3.6.1.2.1.80.0.3 |
정보 |
SNMP_TRAP_PING_ TEST_COMPLETED |
|
|
traceRoutePathChange |
1.3.6.1.2.1.81.0.1 |
정보 |
변경 SNMP_TRAP_TRACE_ ROUTE_PATH_ |
|
|
traceRouteTestFailed |
1.3.6.1.2.1.81.0.2 |
정보 |
SNMP_TRAP_TRACE_ ROUTE_TEST_FAILED |
|
|
traceRouteTestCompleted |
1.3.6.1.2.1.81.0.3 |
정보 |
SNMP_TRAP_TRACE_ ROUTE_TEST_ 완료 |
|
| RMON 알람 | ||||
|
RFC 2819a, RMON MIB |
떨어지는 알람 |
1.3.6.1.2.1.16.0.1 |
– |
– |
|
상승알람 |
1.3.6.1.2.1.16.0.2 |
– |
– |
|
| 라우팅 알림 | ||||
|
BGP 4 MIB |
bgp설립 |
1.3.6.1.2.1.15.7.1 |
– |
– |
|
bgpBackwardTransition |
1.3.6.1.2.1.15.7.2 |
– |
– |
|
|
OSPF 트랩 MIB |
ospfVirtIfStateChange |
1.3.6.1.2.1.14.16.2.1 |
– |
– |
|
ospfNbrStateChange |
1.3.6.1.2.1.14.16.2.2 |
– |
– |
|
|
ospfVirtNbrStateChange |
1.3.6.1.2.1.14.16.2.3 |
– |
– |
|
|
ospfIfConfigError |
1.3.6.1.2.1.14.16.2.4 |
– |
– |
|
|
ospfVirtIfConfigError |
1.3.6.1.2.1.14.16.2.5 |
– |
– |
|
|
ospfIfAuthFailure |
1.3.6.1.2.1.14.16.2.6 |
– |
– |
|
|
ospfVirtIfAuthFailure |
1.3.6.1.2.1.14.16.2.7 |
– |
– |
|
|
ospfIfRxBadPacket |
1.3.6.1.2.1.14.16.2.8 |
– |
– |
|
|
ospfVirtIfRxBadPacket |
1.3.6.1.2.1.14.16.2.9 |
– |
– |
|
|
ospfTx재전송 |
1.3.6.1.2.1.14.16.2.10 |
– |
– |
|
|
ospfVirtIfTx재전송 |
1.3.6.1.2.1.14.16.2.11 |
– |
– |
|
|
ospfMaxAgeLsa |
1.3.6.1.2.1.14.16.2.13 |
– |
– |
|
|
ospfIfState변경 |
1.3.6.1.2.1.14.16.2.16 |
– |
– |
|
| 시작 알림 | ||||
|
RFC 1907, SNMPv2(Simple Network Management Protocol version 2)에 대한 관리 정보 베이스 |
콜드스타트 |
1.3.6.1.6.3.1.1.5.1 |
위험 |
SNMPD_TRAP_ COLD_START |
|
웜스타트 |
1.3.6.1.6.3.1.1.5.2 |
오류 |
SNMPD_TRAP_ WARM_START |
|
|
authenticationFailure |
1.3.6.1.6.3.1.1.5.5 |
주의 사항 |
SNMPD_TRAP_ GEN_FAILURE |
|
| VRRP 알림 | ||||
|
RFC 2787, 가상 라우터 중복 프로토콜에 대한 매니지드 객체의 정의 |
vrrpTrapNewMaster |
1.3.6.1.2.1.68.0.1 |
경고 |
VRRPD_ NEWMASTER_ 트랩 |
|
vrrpTrapAuthFailure |
1.3.6.1.2.1.68.0.2 |
경고 |
VRRPD_AUTH_ FAILURE_ 트랩 |
|
|
소스 MIB |
트랩 이름 |
SNMP 트랩 OID |
시스템 로깅 심각도 수준 |
시스템 로그 태그 |
|---|---|---|---|---|
| 섀시 (알람 조건) 알림 | ||||
|
섀시 MIB (mib-jnx-chassis) |
jnx전원 공급 장치 장애 |
1.3.6.1.4.1.2636.4.1.1 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
jnxFanFailure |
1.3.6.1.4.1.2636.4.1.2 |
위험 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx과열 |
1.3.6.1.4.1.2636.4.1.3 |
위험 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru제거 |
1.3.6.1.4.1.2636.4.1.5 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru삽입 |
1.3.6.1.4.1.2636.4.1.6 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru전원 끄기 |
1.3.6.1.4.1.2636.4.1.7 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFruPowerOn |
1.3.6.1.4.1.2636.4.1.8 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru실패 |
1.3.6.1.4.1.2636.4.1.9 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru오프라인 |
1.3.6.1.4.1.2636.4.1.10 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru온라인 |
1.3.6.1.4.1.2636.4.1.11 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnxFru체크 |
1.3.6.1.4.1.2636.4.1.12 |
주의 사항 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx전원 공급 장치OK |
1.3.6.1.4.1.2636.4.2.1 |
위험 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx팬OK |
1.3.6.1.4.1.2636.4.2.2 |
위험 |
CHASSISD_ SNMP_ 트랩 |
|
|
jnx온도OK |
1.3.6.1.4.1.2636.4.2.3 |
경고 |
CHASSISD_ SNMP_ 트랩 |
|
| 구성 알림 | ||||
|
구성 관리 MIB (mib-jnx-cfgmgmt) |
jnxCmCfg변경 |
1.3.6.1.4.1.2636.4.5.0.1 |
– |
– |
|
jnxCmRescueChange |
1.3.6.1.4.1.2636.4.5.0.2 |
– |
– |
|
| 원격 운영 알림 | ||||
|
Ping MIB (mib-jnx-ping) |
jnxPingRtt임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.1 |
– |
– |
|
jnxPingRttStdDev임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.2 |
– |
– |
|
|
jnxPingRttJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.3 |
– |
– |
|
|
jnxPingEgress임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.4 |
– |
– |
|
|
jnxPingEgressStdDev임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.5 |
– |
– |
|
|
jnxPingEgressJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.6 |
– |
– |
|
|
jnxPingIngressThreshold 초과 |
1.3.6.1.4.1.2636.4.9.0.7 |
– |
– |
|
|
jnxPingIngressStddev임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.8 |
– |
– |
|
|
jnxPingIngressJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.9 |
– |
– |
|
| RMON 알람 | ||||
|
RMON MIB (mib-jnx-rmon) |
jnxRmonAlarmGetFailure |
1.3.6.1.4.1.2636.4. 3.0.1 |
– |
– |
|
jnxRmonGetOk |
1.3.6.1.4.1.2636.4. 3.0.2 |
– |
– |
|
QFabric 시스템에서 지원되는 SNMP 트랩
QFabric 시스템은 표준 SNMPv2 트랩과 주니퍼 네트웍스 엔터프라이즈별 SNMPv2 트랩을 지원합니다.
QFabric 시스템은 SNMPv1 트랩을 지원하지 않습니다.
자세한 정보는 다음을 참조하십시오.
|
정의 위치 |
트랩 이름 |
SNMP 트랩 OID |
시스템 로깅 심각도 수준 |
Syslog 태그 |
|---|---|---|---|---|
| 링크 알림 | ||||
|
RFC 2863, 인터페이스 그룹 MIB |
링크다운 |
1.3.6.1.6.3.1.1.5.3 |
경고 |
SNMP_TRAP_ LINK_DOWN |
|
링크업 |
1.3.6.1.6.3.1.1.5.4 |
정보 |
SNMP_TRAP_ LINK_UP |
|
| 시작 알림 | ||||
|
RFC 1907, SNMPv2(Simple Network Management Protocol version 2)에 대한 관리 정보 베이스 |
콜드스타트 |
1.3.6.1.6.3.1.1.5.1 |
위험 |
SNMPD_TRAP_ COLD_START |
|
웜스타트 |
1.3.6.1.6.3.1.1.5.2 |
오류 |
SNMPD_TRAP_ WARM_START |
|
|
authenticationFailure |
1.3.6.1.6.3.1.1.5.5 |
주의 사항 |
SNMPD_TRAP_ GEN_FAILURE |
|
|
소스 MIB |
트랩 이름 |
SNMP 트랩 OID |
시스템 로깅 심각도 수준 |
시스템 로그 태그 |
|---|---|---|---|---|
|
패브릭 섀시 MIB (mib-jnx-fabric- chassis) |
패브릭 섀시(알람 조건) 알림 | |||
|
jnxFabricPowerSupplyFailure(jnxFabricPowerSupply) 장애 |
1.3.6.1.4.1.2636.4.19.1 |
경고 |
– |
|
|
jnxFabricFanFail |
1.3.6.1.4.1.2636.4.19.2 |
위험 |
– |
|
|
jnxFabricOverTemperature |
1.3.6.1.4.1.2636.4.19.3 |
경고 |
– |
|
|
jnxFabric Redundancy전환 |
1.3.6.1.4.1.2636.4.19.4 |
주의 사항 |
– |
|
|
jnxFabricFruRemoval |
1.3.6.1.4.1.2636.4.19.5 |
주의 사항 |
– |
|
|
jnxFabricFru삽입 |
1.3.6.1.4.1.2636.4.19.6 |
주의 사항 |
– |
|
|
jnxFabricFru전원 끄기 |
1.3.6.1.4.1.2636.4.19.7 |
주의 사항 |
– |
|
|
jnxFabricFruPowerOn |
1.3.6.1.4.1.2636.4.19.8 |
주의 사항 |
– |
|
|
jnxFabricFruFailed(실패) |
1.3.6.1.4.1.2636.4.19.9 |
경고 |
– |
|
|
jnxFabricFru오프라인 |
1.3.6.1.4.1.2636.4.19.10 |
주의 사항 |
– |
|
|
jnxFabricFruOnline |
1.3.6.1.4.1.2636.4.19.11 |
주의 사항 |
– |
|
|
jnxFabricFruCheck |
1.3.6.1.4.1.2636.4.19.12 |
경고 |
– |
|
|
jnxFabricFEBSwitchover |
1.3.6.1.4.1.2636.4.19.13 |
경고 |
– |
|
|
jnxFabricHardDiskFailed |
1.3.6.1.4.1.2636.4.19.14 |
경고 |
– |
|
|
jnxFabricHardDiskMissing |
1.3.6.1.4.1.2636.4.19.15 |
경고 |
– |
|
|
jnxFabricBootFromBackup |
1.3.6.1.4.1.2636.4.19.16 |
경고 |
– |
|
| 패브릭 섀시(알람 삭제 조건) 알림 | ||||
|
jnxFabricPowerSupplyOK |
1.3.6.1.4.1.2636.4.20.1 |
위험 |
– |
|
|
jnxFabricFanOK |
1.3.6.1.4.1.2636.4.20.2 |
위험 |
– |
|
|
jnxFabricTemperatureOK |
1.3.6.1.4.1.2636.4.20.3 |
경고 |
– |
|
|
jnxFabricFruOK |
1.3.6.1.4.1.2636.4.20.4 |
– |
– |
|
|
QFabric MIB (mib-jnx-qf-smi) |
QFabric MIB 알림 | |||
|
jnxQFabricDownloadIssued |
1.3.6.1.4.1.2636.3.42.1.0.1 |
– |
– |
|
|
jnxQFabricDownloadFailed |
1.3.6.1.4.1.2636.3.42.1.0.2 |
– |
– |
|
|
jnxQFabricDownloadSucceeded |
1.3.6.1.4.1.2636.3.42.1.0.3 |
– |
– |
|
|
jnxQFabricUpgradeIssued |
1.3.6.1.4.1.2636.3.42.1.0.4 |
– |
– |
|
|
jnxQFabricUpgradeFailed |
1.3.6.1.4.1.2636.3.42.1.0.5 |
– |
– |
|
|
jnxQFabricUpgradeSucceeded |
1.3.6.1.4.1.2636.3.42.1.0.6 |
– |
– |
|
| 구성 알림 | ||||
|
구성 관리 MIB (mib-jnx-cfgmgmt) |
jnxCmCfg변경 |
1.3.6.1.4.1.2636.4.5.0.1 |
– |
– |
|
jnxCmRescueChange |
1.3.6.1.4.1.2636.4.5.0.2 |
– |
– |
|
| 원격 운영 알림 | ||||
|
Ping MIB (mib-jnx-ping) |
jnxPingRtt임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.1 |
– |
– |
|
jnxPingRttStdDev임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.2 |
– |
– |
|
|
jnxPingRttJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.3 |
– |
– |
|
|
jnxPingEgress임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.4 |
– |
– |
|
|
jnxPingEgressStdDev임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.5 |
– |
– |
|
|
jnxPingEgressJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.6 |
– |
– |
|
|
jnxPingIngressThreshold 초과 |
1.3.6.1.4.1.2636.4.9.0.7 |
– |
– |
|
|
jnxPingIngressStddev임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.8 |
– |
– |
|
|
jnxPingIngressJitter임계값 초과 |
1.3.6.1.4.1.2636.4.9.0.9 |
– |
– |
|
또한보십시오
Junos OS에서 지원하는 표준 SNMP 트랩
이 주제는 Junos OS를 실행하는 디바이스에서 지원하는 표준 SNMPv1 및 SNMPv2 트랩 목록을 제공합니다. 트랩에 대한 자세한 내용은 SNMP MIB 탐색기를 참조하십시오.
GRES(Graceful Routing Engine switchover) 이후, 새로운 기본 라우팅 엔진은 단일 warmStart 알림을 보냅니다. 기본 라우팅 엔진은 디바이스가 올라갈 때 알림을 보냅니다 coldStart . 또한 기본 라우팅 엔진은 warmStart SNMP 데몬의 후속 재시작에 대한 알림을 보냅니다. GRES가 끝난 후 새로운 기본 라우팅 엔진은 단일 warmStart 알림을 전송하고 백업 라우팅 엔진은 어떠한 알림도 보내지 않습니다.
표준 SNMP 버전 1 트랩
표 7 은 SNMPv1의 표준 트랩에 대한 개요를 제공합니다. 트랩은 트랩 범주로 먼저 조직된 다음 트랩 이름으로 구성되며, 엔터프라이즈 ID, 일반 트랩 번호 및 특정 트랩 번호가 포함됩니다. 시스템 로깅 심각도 수준은 해당 시스템 로그 태그가 있는 트랩에 나열됩니다. 해당 시스템 로깅 심각도 수준을 갖지 않은 트랩은 테이블에서 짧은 대시(-)로 표시됩니다.
시스템 로그 메시지에 대한 자세한 내용은 시스템 로그 탐색기를 참조하십시오.
|
정의 위치 |
트랩 이름 |
엔터프라이즈 ID |
일반 트랩 번호 |
특정 트랩 번호 |
시스템 로깅 심각도 수준 |
Syslog 태그 |
지원되는 곳 |
|---|---|---|---|---|---|---|---|
| 시작 알림 | |||||||
|
RFC 1215, SNMP와 함께 사용하기 위한 트랩 정의 규칙 |
|
1.3.6.1.4.1.2636 |
4 |
0 |
주의 사항 |
SNMPD_ TRAP_ GEN_FAILURE |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.4.1.2636 |
0 |
0 |
위험 |
SNMPD_TRAP_ COLD_START |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.4.1.2636 |
1 |
0 |
오류 |
SNMPD_TRAP_ WARM_START |
Junos OS를 실행하는 모든 디바이스. |
|
| 링크 알림 | |||||||
|
RFC 1215, SNMP와 함께 사용하기 위한 트랩 정의 규칙 |
|
1.3.6.1.4.1.2636 |
2 |
0 |
경고 |
SNMP_ TRAP_ LINK_DOWN |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.4.1.2636 |
3 |
0 |
정보 |
SNMP_TRAP_ LINK_UP |
Junos OS를 실행하는 모든 디바이스. |
|
| 원격 운영 알림 | |||||||
|
RFC 2925, 원격 핑, 경로 추적, 조회 작업에 대한 매니지드 객체의 정의 |
|
1.3.6.1.2.1.80.0 |
6 |
1 |
정보 |
SNMP_TRAP _PING_ PROBE_ 실패했습니다. |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.80.0 |
6 |
2 |
정보 |
SNMP_TRAP_ PING_TEST _FAILED |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.80.0 |
6 |
3 |
정보 |
SNMP_TRAP_ PING_TEST_ 완료 |
Junos OS를 실행하는 모든 디바이스. |
|
| RMON 알람 | |||||||
|
RFC 2819a, RMON MIB |
|
1.3.6.1.2.1.16 |
6 |
2 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.16 |
6 |
1 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
| 라우팅 알림 | |||||||
|
BGP 4 MIB |
|
1.3.6.1.2.1.15.7 |
6 |
1 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
1.3.6.1.2.1.15.7 |
6 |
2 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
OSPF 트랩 MIB |
|
1.3.6.1.2.1.14.16.2 |
6 |
1 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
1.3.6.1.2.1.14.16.2 |
6 |
2 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
3 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
4 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
5 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
6 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
7 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
8 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
9 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
10 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
11 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
13 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
|
|
1.3.6.1.2.1.14.16.2 |
6 |
16 |
– |
– |
MX 및 EX 시리즈 디바이스, SRX 시리즈 방화벽. |
|
| VRRP 알림 | |||||||
|
RFC 2787, 가상 라우터 중복 프로토콜에 대한 매니지드 객체의 정의 |
|
1.3.6.1.2.1.68 |
6 |
1 |
경고 |
VRRPD_NEW MASTER_TRAP |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.68 |
6 |
2 |
경고 |
VRRPD_AUTH_ FAILURE_TRAP |
Junos OS를 실행하는 모든 디바이스. |
|
|
RFC 6527, 가상 라우터 중복 프로토콜 버전 3(VRRPv3)에 대한 매니지드 객체의 정의 |
|
1.3.6.1.2.1.207 |
6 |
1 |
경고 |
VRRPD_NEW_MASTER |
MX 시리즈 디바이스. |
|
|
1.3.6.1.2.1.207 |
6 |
2 |
경고 |
VRRPD_V3_PROTO_ERROR |
MX 시리즈 디바이스. |
|
표준 SNMP 버전 2 트랩
표 8 은 Junos OS에서 지원하는 표준 SNMPv2 트랩에 대한 개요를 제공합니다. 트랩은 트랩 범주에 의해 먼저 조직된 다음 트랩 이름 snmpTrapOID으로 구성되며 해당 . 시스템 로깅 심각도 수준은 해당 시스템 로그 태그가 있는 트랩에 나열됩니다. 해당 시스템 로깅 심각도 수준을 갖지 않은 트랩은 테이블에서 짧은 대시(-)로 표시됩니다.
|
정의 위치 |
트랩 이름 |
snmpTrapOID |
시스템 로깅 심각도 수준 |
Syslog 태그 |
지원되는 곳 |
|---|---|---|---|---|---|
| 시작 알림 | |||||
|
RFC 1907, SNMPv2(Simple Network Management Protocol version 2)에 대한 관리 정보 베이스 |
|
1.3.6.1.6.3.1.1.5.1 |
위험 |
SNMPD_TRAP_ COLD_START |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.6.3.1.1.5.2 |
오류 |
SNMPD_TRAP_ WARM_START |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.6.3.1.1.5.5 |
주의 사항 |
SNMPD_TRAP_ GEN_FAILURE |
Junos OS를 실행하는 모든 디바이스. |
|
| 링크 알림 | |||||
|
RFC 2863, 인터페이스 그룹 MIB |
|
1.3.6.1.6.3.1.1.5.3 |
경고 |
SNMP_TRAP_ LINK_DOWN |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.6.3.1.1.5.4 |
정보 |
SNMP_TRAP_ LINK_UP |
Junos OS를 실행하는 모든 디바이스. |
|
| 원격 운영 알림 | |||||
|
RFC 2925, 원격 핑, 경로 추적, 조회 작업에 대한 매니지드 객체의 정의 |
|
1.3.6.1.2.1.80.0.1 |
정보 |
SNMP_TRAP_ PING_PROBE_ 실패했습니다. |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.80.0.2 |
정보 |
SNMP_TRAP_PING_ TEST_FAILED |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.80.0.3 |
정보 |
SNMP_TRAP_PING_ TEST_COMPLETED |
Junos OS를 실행하는 모든 디바이스. |
|
| RMON 알람 | |||||
|
RFC 2819a, RMON MIB |
|
1.3.6.1.2.1.16.0.1 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.16.0.2 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
| 라우팅 알림 | |||||
|
BGP 4 MIB |
|
1.3.6.1.2.1.15.7.1 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.15.7.2 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
OSPF 트랩 MIB |
|
1.3.6.1.2.1.14.16.2.1 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.14.16.2.2 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.3 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.4 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.5 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.6 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.7 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.8 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.9 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.10 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.11 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.13 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
|
|
1.3.6.1.2.1.14.16.2.16 |
– |
– |
Junos OS를 실행하는 모든 디바이스. |
|
| MPLS 알림 | |||||
|
RFC 3812, MPLS(Multiprotocol Label Switching) 트래픽 엔지니어링(TE) 관리 정보 베이스 |
|
||||
|
|
|||||
|
|
|||||
|
|
|||||
| 엔터티 상태 MIB 알림 | |||||
|
RFC 4268, 엔터티 상태 MIB |
|
1.3.6.1.2.1.131.0.1 |
주의 사항 |
CHASSISD_SNMP_TRAP3 |
MX240, MX480 및 MX960 |
|
|
1.3.6.1.2.1.131.0.2 |
주의 사항 |
CHASSISD_SNMP_TRAP3 |
MX240, MX480 및 MX960 |
|
| L3VPN 알림 | |||||
|
RFC 4382, MPLS/BGP 레이어 3 가상 사설망(VPN) |
|
||||
|
|
|||||
|
|
|||||
|
|
|||||
|
|
|||||
| VRRP 알림 | |||||
|
RFC 2787, 가상 라우터 중복 프로토콜에 대한 매니지드 객체의 정의 |
|
1.3.6.1.2.1.68.0.1 |
경고 |
VRRPD_ NEWMASTER_ 트랩 |
Junos OS를 실행하는 모든 디바이스. |
|
|
1.3.6.1.2.1.68.0.2 |
경고 |
VRRPD_AUTH_ FAILURE_ 트랩 |
Junos OS를 실행하는 모든 디바이스. |
|
|
RFC 6527, 가상 라우터 중복 프로토콜 버전 3(VRRPv3)에 대한 매니지드 객체의 정의 |
|
1.3.6.1.2.1.207.0.1 |
경고 |
VRRPD_NEW_MASTER |
MX 시리즈 디바이스. |
|
|
1.3.6.1.2.1.207.0.2 |
경고 |
VRRPD_V3_PROTO_ERROR |
MX 시리즈 디바이스. |
|
또한보십시오
Syslog 트랩을 위한 맞춤형 SNMP 관리 정보 베이스(MIB)
SNMP syslog 트랩은 SNMP가 활성화된 원격 디바이스가 중앙 수집기로 전송되어 구성 요소 장애가 발생했거나 중요 리소스가 구성 가능한 제한을 벗어났음을 알리는 경고 메시지입니다. 이 정보는 관리 정보 베이스(MIB)에 캡처됩니다. 주니퍼 네트웍스 엔터프라이즈별 시스템 로그 MIB는 중요한 시스템 로그 메시지가 발생할 때 SNMP 트랩 기반 애플리케이션의 알림을 활성화합니다. MIB는 syslog 항목을 일반 jnxSyslogTrap OID에 매핑하도록 정의됩니다.
jnxSyslogTrap OID는 syslog에서 생성된 로그를 기반으로 하는 트랩입니다. 이벤트 프로세스(eventd)는 syslog를 모니터링하고 syslog 이벤트에 대한 이벤트 정책 raise-trap 구성 명령문을 기반으로 모든 syslog 이벤트를 하나의 일반 syslog 정의 트랩 MIB인 jnxSyslogTrap으로 보냅니다.
하나의 일반 MIB OID를 사용하면 OID가 동일한 알람을 구분하는 것이 불가능하기 때문에 syslog 트랩 OID 값을 처리하여 특정 이벤트를 찾으려는 고객에게는 불편합니다. 그러나 Junos OS 릴리스 18.3R1부터는 사용자 지정 OID를 특정 로그에 매핑하여 디바이스에 동적으로 로드할 수 있습니다.
이 기능의 장점은 특정 OID를 여러 유형의 syslog 이벤트에 할당할 수 있기 때문에 이제 각각의 다른 유형의 syslog 이벤트를 효과적으로 모니터링할 수 있다는 것입니다.
- 사용자 지정 SNMP 관리 정보 베이스(MIB)에 대한 개요
- syslog 트랩에 대한 사용자 지정 MIB 정의
- 사용자 지정 SNMP 트랩 사용의 한계
- 사용자 지정 syslog 트랩의 예
사용자 지정 SNMP 관리 정보 베이스(MIB)에 대한 개요
syslog 트랩에 대한 사용자 지정 SNMP MIB를 생성하려면 다음 작업을 완료해야 합니다.
-
사용자 지정 MIB를 작성합니다.
-
MIB 파일을 YANG 형식으로 변환하고 YANG 파일을 디바이스로 복사합니다.
-
YANG 파일을 디바이스에 로드합니다.
다음 섹션에서는 이러한 단계에 대한 개요를 설명합니다.
MIB 파일 작성
특정 로그를 사용자 지정 OID와 매핑하기 전에 사용자 지정 MIB를 작성해야 합니다. 충돌을 피하기 위해, 표 9에 표시된 예약된 루트 아래에서만 MIB 개체와 트랩을 정의해야 합니다.
|
루트 |
설명 |
OID |
|---|---|---|
|
|
사용자 지정 MIB 모듈 |
.1.3.6.1.4.1.2636.3.86 |
|
|
사용자 지정 트랩 알림 |
.1.3.6.1.4.1.2636.4.30 |
YANG 파일로 변환
MIB 정의를 디바이스에 로드하기 전에 MIB 파일을 YANG 형식으로 변환해야 합니다. MIB 파일을 YANG으로 변환하는 권장 방법은 smidump v0.5.0 도구를 사용하는 것입니다. smidump 도구는 노트북에 설치할 수 있는 오픈 소스 응용 프로그램입니다( https://www.ibr.cs.tu-bs.de/projects/libsmi/smidump.html 참조).
파일이 YANG 형식이 되면 디바이스로 복사해야 합니다. 그런 다음 CLI 명령을 사용하여 SNMP 프로세스(snmpd)에 로드합니다. 그런 다음 해당 JSON 파일이 생성되고 snmpd가 구문 분석하고 이를 기반으로 OID 계층의 데이터베이스가 구축됩니다. 알 수 없는 태그가 발견되면 snmpd는 적절한 오류 메시지를 반환합니다.
YANG 파일 관리에 사용할 CLI 명령
YANG 모듈을 snmpd에 로드하려면 다음 명령과 함께 옵션을 사용합니다snmp.request system yang add
user@host> request system yang add snmp module yang-filename package package-name
절 yang-filename 대 경로가 포함됩니다.
명령을 실행 request system yang add 하려면 슈퍼유저 액세스 권한이 있어야 합니다.
디바이스에서 YANG 파일을 관리하기 위한 다른 두 개의 명령이 있습니다: show system yang package 및 request system yang delete.
또한보십시오
syslog 트랩에 대한 사용자 지정 MIB 정의
이 절차에서는 다음 예제 파일을 사용합니다.
-
변환할 MIB 파일
-
출력
이 문서에 제공된 예제 YANG을 참조하여 YANG을 수동으로 작성할 수 있지만 smidump 도구 v0.5.0을 사용하여 MIB를 YANG 형식으로 변환하는 것이 좋습니다.
syslog 트랩에 대한 사용자 지정 MIB를 정의하려면:
mib-jnx-example-custom-syslog.txt
-- *******************************************************************
-- Juniper enterprise specific custom syslog MIB.
--
-- Copyright (c) 2002-2004, 2006, Juniper Networks, Inc.
-- All rights reserved.
--
-- The contents of this document are subject to change without notice.
-- *******************************************************************
JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB DEFINITIONS ::= BEGIN
IMPORTS
MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE, Integer32
FROM SNMPv2-SMI
jnxCustomMibRoot, jnxCustomSyslogNotifications
FROM JUNIPER-SMI
ifName
FROM IF-MIB
;
jnxExampleCustomSyslog MODULE-IDENTITY
LAST-UPDATED "201711270000Z"
ORGANIZATION "Juniper Networks, Inc."
CONTACT-INFO
"Juniper Technical Assistance Center
Juniper Networks, Inc.
1133 Innovation Way
Sunnyvale, CA 94089
E-mail: support@juniper.net"
DESCRIPTION
"Example MIB objects for custom syslog"
REVISION "201711270000Z"
DESCRIPTION
"Initial draft"
::= { jnxCustomMibRoot 1 }
jnxExampleCustomSyslogMessage OBJECT-TYPE
SYNTAX OCTET STRING
MAX-ACCESS accessible-for-notify
STATUS current
DESCRIPTION
"The syslog message string."
::= { jnxExampleCustomSyslog 1 }
jnxExampleCustomSyslogInteger OBJECT-TYPE
SYNTAX Integer32
MAX-ACCESS accessible-for-notify
STATUS current
DESCRIPTION
"Example OID for adding custom Integer OID"
::= { jnxExampleCustomSyslog 2 }
jnxExampleSyslogTrap1 NOTIFICATION-TYPE
OBJECTS { jnxExampleCustomSyslogMessage }
STATUS current
DESCRIPTION
"This TRAP is reserved to be sent when event 1 occurs"
::= { jnxCustomSyslogNotifications 1 }
jnxExampleSyslogTrap2 NOTIFICATION-TYPE
OBJECTS { jnxExampleCustomSyslogInteger, jnxExampleCustomSyslogMessage }
STATUS current
DESCRIPTION
"This TRAP is reserved to be sent when event 2 occurs"
::= { jnxCustomSyslogNotifications 2 }
jnxExampleSyslogTrap3 NOTIFICATION-TYPE
OBJECTS { ifName, jnxExampleCustomSyslogMessage }
STATUS current
DESCRIPTION
"This TRAP is reserved to be sent when event 3 occurs"
::= { jnxCustomSyslogNotifications 3 }
END
JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB.YANG입니다.
/*
* This YANG module has been generated by smidump 0.5.0:
*
* smidump -f yang JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB
*
* Do not edit. Edit the source file instead!
*/
module JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB {
namespace "urn:ietf:params:xml:ns:yang:smiv2:JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB";
prefix "juniper-example";
import IF-MIB {
prefix "if-mib";
}
import JUNIPER-SMI {
prefix "juniper-smi";
}
import ietf-yang-smiv2 {
prefix "smiv2";
}
organization
"Juniper Networks, Inc.";
contact
"Juniper Technical Assistance Center
Juniper Networks, Inc.
1133 Innovation Way
Sunnyvale, CA 94089
E-mail: support@juniper.net";
description
"Example MIB objects for custom syslog";
revision 2017-11-27 {
description
"Initial draft";
}
container JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB {
config false;
}
notification jnxExampleSyslogTrap1 {
description
"This TRAP is reserved to be sent when event 1 occurs";
smiv2:oid "1.3.6.1.4.1.2636.4.30.1";
container object-1 {
leaf jnxExampleCustomSyslogMessage {
type binary;
description
"The syslog message string.";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.1";
}
}
}
notification jnxExampleSyslogTrap2 {
description
"This TRAP is reserved to be sent when event 2 occurs";
smiv2:oid "1.3.6.1.4.1.2636.4.30.2";
container object-1 {
leaf jnxExampleCustomSyslogInteger {
type int32;
description
"Example OID for adding custom Integer OID";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.2";
}
}
container object-2 {
leaf jnxExampleCustomSyslogMessage {
type binary;
description
"The syslog message string.";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.1";
}
}
}
notification jnxExampleSyslogTrap3 {
description
"This TRAP is reserved to be sent when event 3 occurs";
smiv2:oid "1.3.6.1.4.1.2636.4.30.3";
container object-1 {
leaf ifIndex {
type leafref {
path "/if-mib:IF-MIB/if-mib:ifTable/if-mib:ifEntry/if-mib:ifIndex";
}
}
leaf ifName {
type leafref {
path "/if-mib:IF-MIB/if-mib:ifTable/if-mib:ifEntry/if-mib:ifName";
}
}
}
container object-2 {
leaf jnxExampleCustomSyslogMessage {
type binary;
description
"The syslog message string.";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.1";
}
}
}
smiv2:alias "jnxExampleCustomSyslog" {
smiv2:oid "1.3.6.1.4.1.2636.3.86.1";
}
}
사용자 지정 SNMP 트랩 사용의 한계
자주 발생하는 syslog에 대한 트랩을 트리거하지 않도록 이벤트 스크립트를 작성하도록 주의해야 합니다. 이렇게 하면 디바이스에 더 많은 부하가 가해지는 것을 방지할 수 있습니다.
액세스 유형이 또는 readwrite인 readonly 개체를 추가하는 경우 해당 개체는 snmpget 또는 snmpwalk와 같은 snmp 폴링 작업에서 폴링에 사용할 수 없으며 액세스 유형notifyonly으로 처리됩니다. 이 기능은 동적 TRAP OID 정의를 디바이스에 추가하여 고객이 각 syslog에 대한 사용자 지정 트랩을 전송하는 스크립트를 작성할 수 있도록 하기 때문입니다. 액세스 유형 readonly 은 SNMP readwrite 폴링용인 반면notifyonly, 트랩용입니다.
사용자 지정 관리 정보 베이스(MIB)의 경우, 사용자 지정 테이블의 정의는 지원되지 않습니다. 테이블 개체가 varbind로 있는 트랩을 보내려면 사용자 지정 MIB에서 사용자 지정 테이블을 정의하는 대신 Junos MIB에서 이미 정의된 테이블을 사용합니다.
YANG 파일은 모든 섀시 노드와 라우팅 엔진에 개별적으로 로드되어야 합니다. 이 명령은 request system yang add 백업 라우팅 엔진에 자동으로 복사하지 않습니다.
사용자 지정 syslog 트랩의 예
이 사용자 지정 syslog 트랩 예는 다음 중 하나가 발생할 때 운영자가 트랩을 수신하려는 사용 사례를 보여줍니다.
-
사용자가 CLI에서 구성 모드에 들어갑니다(로
ui_dbase_login_event정의된 이벤트). -
사용자가 커밋을 수행합니다(이벤트는 다음과 같이 정의됨
ui_commit)
사용자 지정 syslog 트랩 기능이 지원되기 전에는 두 이벤트 모두에 대해 고정 OID가 있는 jnxSyslogTrap을 사용하는 것이 유일한 방법이었습니다. 이제 사용자 지정 syslog 트랩 기능을 사용하여 사용자 지정 정의 OID가 있는 트랩을 생성할 수 있습니다.
사용자 지정 syslog 트랩을 정의하려면 다음을 수행합니다.
샘플 MIB 파일
-- *******************************************************************
-- Juniper enterprise specific custom syslog MIB.
--
-- Copyright (c) 2002-2004, 2006, Juniper Networks, Inc.
-- All rights reserved.
--
-- The contents of this document are subject to change without notice.
-- *******************************************************************
JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB DEFINITIONS ::= BEGIN
IMPORTS
MODULE-IDENTITY, OBJECT-TYPE, NOTIFICATION-TYPE
FROM SNMPv2-SMI
jnxCustomMibRoot, jnxCustomSyslogNotifications
FROM JUNIPER-SMI
;
jnxExampleCustomSyslog MODULE-IDENTITY
LAST-UPDATED "201806220000Z"
ORGANIZATION "Juniper Networks, Inc."
CONTACT-INFO
"Juniper Technical Assistance Center
Juniper Networks, Inc.
1133 Innovation Way
Sunnyvale, CA 94089
E-mail: support@juniper.net"
DESCRIPTION
"Example MIB objects for custom syslog"
REVISION "201806220000Z"
DESCRIPTION
"Initial draft"
::= { jnxCustomMibRoot 1 }
username OBJECT-TYPE
SYNTAX OCTET STRING
MAX-ACCESS accessible-for-notify
STATUS current
DESCRIPTION
"Username"
::= { jnxExampleCustomSyslog 1 }
command OBJECT-TYPE
SYNTAX OCTET STRING
MAX-ACCESS accessible-for-notify
STATUS current
DESCRIPTION
"Executed command"
::= { jnxExampleCustomSyslog 2 }
comment OBJECT-TYPE
SYNTAX OCTET STRING
MAX-ACCESS accessible-for-notify
STATUS current
DESCRIPTION
"Additional comment"
::= { jnxExampleCustomSyslog 3 }
enteredConfigMode NOTIFICATION-TYPE
OBJECTS { username }
STATUS current
DESCRIPTION
"This TRAP is sent when a user enteres config mode. "
::= { jnxCustomSyslogNotifications 1 }
configCommitted NOTIFICATION-TYPE
OBJECTS { username, command, comment }
STATUS current
DESCRIPTION
"This TRAP is sent when a user does config commit"
::= { jnxCustomSyslogNotifications 2 }
END
샘플 YANG 변환 파일
/*
* This YANG module has been generated by smidump 0.5.0:
*
* smidump -f yang JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB
*
* Do not edit. Edit the source file instead!
*/
module JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB {
namespace "urn:ietf:params:xml:ns:yang:smiv2:JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB";
prefix "juniper-example";
import JUNIPER-SMI {
prefix "juniper-smi";
}
import ietf-yang-smiv2 {
prefix "smiv2";
}
organization
"Juniper Networks, Inc.";
contact
"Juniper Technical Assistance Center
Juniper Networks, Inc.
1133 Innovation Way
Sunnyvale, CA 94089
E-mail: support@juniper.net";
description
"Example MIB objects for custom syslog";
revision 2018-06-22 {
description
"Initial draft";
}
container JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB {
config false;
}
notification enteredConfigMode {
description
"This TRAP is sent when a user enteres config mode. ";
smiv2:oid "1.3.6.1.4.1.2636.4.30.1";
container object-1 {
leaf username {
type binary;
description
"Username";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.1";
}
}
}
notification configCommitted {
description
"This TRAP is sent when a user does config commit";
smiv2:oid "1.3.6.1.4.1.2636.4.30.2";
container object-1 {
leaf username {
type binary;
description
"Username";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.1";
}
}
container object-2 {
leaf command {
type binary;
description
"Executed command";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.2";
}
}
container object-3 {
leaf comment {
type binary;
description
"Additional comment";
smiv2:max-access "accessible-for-notify";
smiv2:oid "1.3.6.1.4.1.2636.3.86.1.3";
}
}
}
smiv2:alias "jnxExampleCustomSyslog" {
smiv2:oid "1.3.6.1.4.1.2636.3.86.1";
}
}
slax 스크립트 cutom_trap.slax(/var/db/scripts/event)
version 1.0;
ns junos = "http://xml.juniper.net/junos/*/junos";
ns xnm = "http://xml.juniper.net/xnm/1.1/xnm";
ns jcs = "http://xml.juniper.net/junos/commit-scripts/1.0";
import "../import/junos.xsl";
match / {
<event-script-results> {
expr jcs:syslog("external.warning",event-script-input/trigger-event/id);
var $id = event-script-input/trigger-event/id;
if ($id == 'UI_DBASE_LOGIN_EVENT'){
var $committing-user = event-script-input/trigger-event/attribute-list/attribute[name=="username"]/value;
var $requestSnmpTrap = <request-snmp-spoof-trap> {
<trap> "enteredConfigMode";
<variable-bindings>
"username=" _ $committing-user;
}
var $snmpTrapResults = jcs:invoke( $requestSnmpTrap );
}
else if ($id == 'UI_COMMIT'){
var $committing-user = event-script-input/trigger-event/attribute-list/attribute[name=="username"]/value;
var $committing-command = event-script-input/trigger-event/attribute-list/attribute[name=="command"]/value;
var $committing-comment = event-script-input/trigger-event/attribute-list/attribute[name=="message"]/value;
var $requestSnmpTrap = <request-snmp-spoof-trap> {
<trap> "configCommitted";
<variable-bindings>
"username=" _ $committing-user _ ", command=" _ $committing-command _ ", comment=" _ $committing-comment;
}
var $snmpTrapResults = jcs:invoke( $requestSnmpTrap );
}
}
}
플랫폼별 SNMP 트랩 동작
기능 탐색기를 사용하여 특정 기능에 대한 플랫폼 및 릴리스 지원을 확인하십시오.
다음 표를 사용하여 플랫폼의 플랫폼별 동작을 검토하십시오.
| 플랫폼 | 차이 |
|---|---|
|
EX 시리즈 |
|
변경 내역 표
기능 지원은 사용 중인 플랫폼과 릴리스에 따라 결정됩니다. 기능 탐색기를 사용하여 플랫폼에서 기능이 지원되는지 확인합니다.