IS-ISでサポートされている標準

Junos OS は、実質的に以下の IS-IS 標準をサポートしています。

  • 国際標準化機構/国際電気標準会議(ISO/IEC)8473、 情報技術 — コネクションレスモードネットワークサービスを提供するプロトコル

  • ISO 9542、 コネクションレスモードネットワークサービスの提供のためのプロトコルと組み合わせて使用するためのエンドシステム間ルーティング交換プロトコル

  • ISO/IEC 10589、 情報技術 — システム間の電気通信と情報交換 — コネクションレスモードネットワークサービスを提供するプロトコル(ISO 8473)と組み合わせて使用する、中間システムから中間システムへのドメイン内ルーティング情報交換プロトコル

  • RFC 1195、 TCP/IPおよびデュアル環境でのルーティングへのOSI IS-ISの使用

  • RFC 5120、 M-IS-IS:中間システムから中間システム(IS-IS)へのマルチトポロジー(MT)ルーティング

  • RFC 5130、 管理タグを使用したIS-ISのポリシー制御メカニズム

  • RFC 5286、 IP高速再ルートの基本仕様:ループフリーの代替ルート

  • RFC 5301、 IS-ISの動的ホスト名交換メカニズム

  • RFC 5302、 2レベルIS-ISを使用したドメインワイドプレフィックス配布

  • RFC 5303、 IS-ISポイントツーポイント隣接関係のスリーウェイハンドシェイク

  • RFC 5304、 IS-IS暗号化認証

  • RFC 5305、 トラフィックエンジニアリングのためのIS-IS拡張

  • RFC 5306、 IS-ISのシグナリングの再起動

  • RFC 5307、 GMPLS(汎用マルチプロトコルラベルスイッチング)をサポートするIS-IS拡張

  • RFC 5308、 IS-ISを使用したIPv6のルーティング

  • RFC 5310、 IS-IS汎用暗号認証

  • RFC 5880、 双方向フォワーディング検出(BFD)

  • RFC 6119、 IS-ISのIPv6トラフィックエンジニアリング

  • RFC 6232、 IS-ISのパージ送信元識別TLV

  • RFC 6233、 パージ用のIS-ISレジストリ拡張

  • RFC 7775、 拡張IPおよびIPv6到達可能性のためのIS-ISルート優先度

  • RFC 7794、 拡張IPv4およびIPv6到達可能性用のIS-ISプレフィックス属性

  • RFC 7981、 アドバタイズルーター情報用のIS-IS拡張

  • RFC 8202、 IS-ISマルチインスタンス

  • RFC 8518、 マルチホームプレフィックスのループフリー代替の選択

  • RFC 8570、 IS-ISトラフィックエンジニアリング(TE)メトリック拡張

  • RFC 8667、 セグメントルーティング用のIS-IS拡張

  • RFC 8706、 IS-ISのシグナリングの再起動

  • RFC 8919、 IS-ISアプリケーション固有のリンク属性

  • RFC 9350 IGPフレキシブルアルゴリズム (部分サポート)

  • RFC 9352、 IPv6データプレーン上でのセグメントルーティングをサポートするためのIS-IS拡張

以下のRFCは標準を定義しませんが、IS-ISおよび関連技術に関する情報を提供します。IETF は、これらを「情報」として分類しています。

  • RFC 2104、 HMAC:メッセージ認証用のキーハッシュ

  • RFC 2973、 IS-ISメッシュグループ

  • RFC 3277、 中間システム間(IS-IS)過渡ブラックホール回避

  • RFC 3358、 中間システム間へのオプションのチェックサム(IS-IS)

  • RFC 3359、 中間システム間システムの予約されたタイプ、長さ、値(TLV)コードポイント

  • RFC 3373、 中間システム間(IS-IS)ポイントツーポイント隣接関係のスリーウェイハンドシェイク

  • RFC 3567、 中間システム間(IS-IS)暗号化認証

  • RFC 3719、 中間システム間システム(IS-IS)を使用した相互運用可能なネットワークに対する推奨事項

  • RFC 3787、 中間システム間(IS-IS)を使用した相互運用可能なIPネットワークに対する推奨事項

  • RFC 3847、 中間システム間へのシグナリングの再起動(IS-IS)

  • RFC 5309、 リンクステートルーティングプロトコルにおけるLANを介したポイントツーポイント運用

  • RFC 6151、 更新 MD5メッセージダイジェストとHMAC-MD5アルゴリズムのセキュリティに関する考慮事項

  • インターネットドラフトdraft-ietf-isis-wg-255adj-02.txt、 IS-ISで255以上の回線を維持

  • インターネットドラフトdraft-przygienda-flood-reflector-00、 フラッドリフレクタ

  • インターネットドラフトdraft-przygienda-lsr-flood-reflection-01、 IS-ISフラッドリフレクション