Junos OSでサポートされているSNMPトラップ

ネットワークデバイスとシステムは、標準のSNMPトラップとエンタープライズ固有のトラップをサポートします。

機能エクスプローラーを使用して、特定の機能のプラットフォームとリリースのサポートを確認します。

プラットフォームに関連する注意事項については、 プラットフォーム固有のSNMPトラップ動作 のセクションを参照してください。

QFXシリーズスタンドアロンスイッチ、QFXシリーズバーチャルシャーシ、QFabricシステムでのSNMPトラップサポート

QFXシリーズスタンドアロンスイッチおよびQFXシリーズバーチャルシャーシでサポートされるSNMPトラップ

QFXシリーズスタンドアロンスイッチとQFXシリーズバーチャルシャーシは、SNMPv1およびSNMPv2トラップをサポートします。詳細については、次を参照してください。

SNMPv1トラップ

QFXシリーズスタンドアロンスイッチとQFXシリーズバーチャルシャーシは、標準のSNMPv1トラップとジュニパーネットワークスエンタープライズ固有のSNMPv1トラップの両方をサポートします。参照:

  • 標準SNMPv1トラップの表1

  • エンタープライズ固有のSNMPv1トラップの表2

トラップは、まずトラップカテゴリ別に、次にトラップ名別に編成されます。トラップがこれらの重大度レベルを持つ場合には、システムログの重大度レベルがリストされています。対応するシステムロギング重大度レベルを持たないトラップには、ダ ッシュ(–)の印が付けられています。

表1:スタンドアロンスイッチおよびQFXシリーズバーチャルシャーシでサポートされる標準SNMPバージョン1トラップQFXシリーズ

定義

トラップ名

エンタープライズID

汎用トラップ番号

特定トラップ番号

システムロギング重大度レベル

Syslogタグ

リンク通知

RFC 1215、 SNMPで使用するトラップを定義するための表記法

リンクダウン

1.3.6.1.4.1.2636

2

0

警告

SNMP_ TRAP_ LINK_DOWN

リンクアップ

1.3.6.1.4.1.2636

3

0

情報

SNMP_TRAP_ LINK_UP

リモート操作通知

RFC 2925、 リモートPing、トレースルート、ルックアップ操作のためのマネージドオブジェクトの定義

pingProbeFailed(pingプローブ失敗)

1.3.6.1.2.1.80.0

6

1

情報

SNMP_TRAP_PING_PROBE_失敗しました

pingTestFailed

1.3.6.1.2.1.80.0

6

2

情報

SNMP_TRAP_ PING_TEST _FAILED

pingTest完了

1.3.6.1.2.1.80.0

6

3

情報

SNMP_TRAP_ PING_TEST_完了しました

traceRoutePath変更

1.3.6.1.2.1.81.0

6

1

情報

SNMP_TRAP_ TRACE_ROUTE_ PATH_CHANGE

traceRouteTestFailed(トレースルートテスト失敗)

1.3.6.1.2.1.81.0

6

2

情報

SNMP_TRAP_ TRACE_ROUTE_ TEST_FAILED

traceRouteTestCompleted(traceRouteTestCompleted)

1.3.6.1.2.1.81.0

6

3

情報

SNMP_TRAP_ TRACE_ROUTE_ TEST_COMPLETED

RMONアラーム

RFC 2819a、 RMON MIB

落下アラーム

1.3.6.1.2.1.16

6

2

–

–

rising アラーム

1.3.6.1.2.1.16

6

1

–

–

ルーティング通知

BGP 4 MIB

bgp設立

1.3.6.1.2.1.15.7

6

1

–

–

bgpBackwardTransition

1.3.6.1.2.1.15.7

6

2

–

–

OSPFトラップMIB

ospfVirtIfStateChange

1.3.6.1.2.1.14.16.2

6

1

–

–

ospfNbrStateChange

1.3.6.1.2.1.14.16.2

6

2

–

–

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2

6

3

–

–

ospfIfConfigError

1.3.6.1.2.1.14.16.2

6

4

–

–

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2

6

5

–

–

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2

6

6

–

–

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2

6

7

–

–

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

8

–

–

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

9

–

–

ospfTx再送信

1.3.6.1.2.1.14.16.2

6

10

–

–

ospfVirtIfTx再送信

1.3.6.1.2.1.14.16.2

6

11

–

–

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2

6

13

–

–

ospfIfStateChange

1.3.6.1.2.1.14.16.2

6

16

–

–

起動通知

RFC 1215、 SNMPで使用するトラップを定義するための表記法

認証失敗

1.3.6.1.4.1.2636

4

0

通知

SNMPD_ TRAP_ GEN_FAILURE

コールドスタート

1.3.6.1.4.1.2636

0

0

クリティカル

SNMPD_TRAP_ COLD_START

warmStart

1.3.6.1.4.1.2636

1

0

エラー

SNMPD_TRAP_ WARM_START

VRRP通知

RFC 2787、 仮想ルーター冗長性プロトコルの管理オブジェクト定義

vrrpTrapNewMaster

1.3.6.1.2.1.68

6

1

警告

VRRPD_NEW MASTER_TRAP

vrrpTrapAuthFailure

1.3.6.1.2.1.68

6

2

警告

VRRPD_AUTH_ FAILURE_TRAP

表2:QFXシリーズスタンドアロンスイッチおよびQFXシリーズバーチャルシャーシでサポートされるエンタープライズ固有のSNMPv1トラップ

定義

トラップ名

エンタープライズID

汎用トラップ番号

特定トラップ番号

システムロギング重大度レベル

システムログタグ

シャーシ通知(アラーム状態)

シャーシMIB (jnx-chassis. mib)

jnxPowerSupply障害

1.3.6.1.4.1.2636.4.1

6

1

警告

CHASSISD_ SNMP_トラップ

jnxFanFailure

1.3.6.1.4.1.26361

6

2

クリティカル

CHASSISD_ SNMP_トラップ

jnxOvertemperature

11.4.1.2636.4.1

6

3

アラート

CHASSISD_ SNMP_トラップ

jnxFruRemoval

1.3.6.1.4.1.2636.4.1

6

5

通知

CHASSISD_ SNMP_トラップ

jnxFru挿入

1.3.6.1.4.1.2636.4.1

6

6

通知

CHASSISD_ SNMP_トラップ

jnxFruPowerOff

1.3.6.1.4.1.2636.4.1

6

7

通知

CHASSISD_ SNMP_トラップ

jnxFruPowerOn

1.3.6.1.4.1.2636.4.1

6

8

通知

CHASSISD_ SNMP_トラップ

jnxFru失敗しました

1.3.6.1.4.1.2636.4.1

6

9

警告

CHASSISD_ SNMP_トラップ

jnxFruオフライン

1.3.6.1.4.1.2636.4.1

6

10

通知

CHASSISD_ SNMP_トラップ

jnxFruOnline

1.3.6.1.4.1.2636.4.1

6

11

通知

CHASSISD_ SNMP_トラップ

jnxFruCheck

1.3.6.1.4.1.2636.4.1

6

12

警告

CHASSISD_ SNMP_トラップ

jnxPowerSupplyOK

1.3.6.1.4.1.2636.4.2

6

1

クリティカル

CHASSISD_ SNMP_トラップ

jnxFanOK

1.3.6.1.4.1.2636.4.2

6

2

クリティカル

CHASSISD_ SNMP_トラップ

jnx温度OK

1.3.6.1.4.1.2636.4.2

6

3

アラート

CHASSISD_ SNMP_トラップ

設定通知

構成管理 MIB (jnx- configmgmt. mib)

jnxCmCfgChange

1.3.6.1.4.1.2636.4.5

6

1

–

–

jnxCmRescue変更

1.3.6.1.4.1.2636.4.5

6

2

–

–

リモート操作

Ping MIB (jnx-ping.mib)

jnxPingRttしきい値超過しました

1.3.6.1.4.1.2636.4.9

6

1

–

–

jnxPingRttStdDevThreshold 超過

1.3.6.1.4.1.2636.4.9

6

2

–

–

jnxPingRttJitterThreshold 超過

1.3.6.1.4.1.2636.4.9

6

3

–

–

jnxPingEgressしきい値を超えました

1.3.6.1.4.1.2636.4.9

6

4

–

–

jnxPingEgressStdDevしきい値超過しました

1.3.6.1.4.1.2636.4.9

6

5

–

–

jnxPingEgressJitterThreshold 超過

1.3.6.1.4.1.2636.4.9

6

6

–

–

jnxPingIngressThreshold 超過

1.3.6.1.4.1.2636.4.9

6

7

–

–

jnxPingIngressStddevしきい値を超えました

1.3.6.1.4.1.2636.4.9

6

8

–

–

jnxPingIngressJitterThreshold 超過

1.3.6.1.4.1.2636.4.9

6

9

–

–

RMONアラーム

RMON MIB (jnx-rmon. mib)

jnxRmonAlarmGetFailure

1.3.6.1.4.1.2636.4.3

6

1

–

–

jnxRmonGetOk

1.3.6.1.4.1.2636.4.3

6

2

–

–

SNMPv2トラップ

  • 表3 に、標準のSNMPトラップを示します

  • 表4 は、ジュニパーネットワークスエンタープライズ固有のトラップを示しています

表3:QFXシリーズスタンドアロンスイッチおよびQFXシリーズバーチャルシャーシでサポートされる標準SNMPv2トラップ

定義

トラップ名

SNMPトラップOID

システムロギング重大度レベル

Syslogタグ

リンク通知

RFC 2863、 インターフェイスグループMIB

リンクダウン

1.3.6.1.6.3.1.1.5.3

警告

SNMP_TRAP_ LINK_DOWN

リンクアップ

1.3.6.1.6.3.1.1.5.4

情報

SNMP_TRAP_ LINK_UP

リモート操作通知

RFC 2925、 リモートPing、トレースルート、ルックアップ操作のためのマネージドオブジェクトの定義

pingProbeFailed(pingプローブ失敗)

1.3.6.1.2.1.80.0.1

情報

SNMP_TRAP_ PING_PROBE_失敗しました

pingTestFailed

1.3.6.1.2.1.80.0.2

情報

SNMP_TRAP_PING_ TEST_FAILED

pingTest完了

1.3.6.1.2.1.80.0.3

情報

SNMP_TRAP_PING_ TEST_COMPLETED

traceRoutePath変更

1.3.6.1.2.1.81.0.1

情報

変更SNMP_TRAP_TRACE_ ROUTE_PATH_

traceRouteTestFailed(トレースルートテスト失敗)

1.3.6.1.2.1.81.0.2

情報

SNMP_TRAP_TRACE_ ROUTE_TEST_FAILED

traceRouteTestCompleted(traceRouteTestCompleted)

1.3.6.1.2.1.81.0.3

情報

SNMP_TRAP_TRACE_ ROUTE_TEST_完了しました

RMONアラーム

RFC 2819a、 RMON MIB

落下アラーム

1.3.6.1.2.1.16.0.1

–

–

rising アラーム

1.3.6.1.2.1.16.0.2

–

–

ルーティング通知

BGP 4 MIB

bgp設立

1.3.6.1.2.1.15.7.1

–

–

bgpBackwardTransition

1.3.6.1.2.1.15.7.2

–

–

OSPFトラップMIB

ospfVirtIfStateChange

1.3.6.1.2.1.14.16.2.1

–

–

ospfNbrStateChange

1.3.6.1.2.1.14.16.2.2

–

–

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2.3

–

–

ospfIfConfigError

1.3.6.1.2.1.14.16.2.4

–

–

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2.5

–

–

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2.6

–

–

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2.7

–

–

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2.8

–

–

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2.9

–

–

ospfTx再送信

1.3.6.1.2.1.14.16.2.10

–

–

ospfVirtIfTx再送信

1.3.6.1.2.1.14.16.2.11

–

–

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2.13

–

–

ospfIfStateChange

1.3.6.1.2.1.14.16.2.16

–

–

起動通知

RFC 1907、簡 易ネットワーク管理プロトコルバージョン2(SNMPv2)の管理情報ベース

コールドスタート

1.3.6.1.6.3.1.1.5.1

クリティカル

SNMPD_TRAP_ COLD_START

warmStart

1.3.6.1.6.3.1.1.5.2

エラー

SNMPD_TRAP_ WARM_START

認証失敗

1.3.6.1.6.3.1.1.5.5

通知

SNMPD_TRAP_ GEN_FAILURE

VRRP通知

RFC 2787、 仮想ルーター冗長性プロトコルの管理オブジェクト定義

vrrpTrapNewMaster

1.3.6.1.2.1.68.0.1

警告

VRRPD_ NEWMASTER_トラップ

vrrpTrapAuthFailure

1.3.6.1.2.1.68.0.2

警告

VRRPD_AUTH_ FAILURE_トラップ

表4:QFXシリーズスタンドアロンスイッチおよびQFXシリーズバーチャルシャーシでサポートされるエンタープライズ固有のSNMPv2トラップ

ソースMIB

トラップ名

SNMPトラップOID

システムロギング重大度レベル

システムログタグ

シャーシ(アラーム状態)の通知

シャーシMIB (mib-jnx-chassis)

jnxPowerSupply障害

1.3.6.1.4.1.2636.4.1.1

アラート

CHASSISD_ SNMP_トラップ

 

jnxFanFailure

1.3.6.1.4.1.2636.4.1.2

クリティカル

CHASSISD_ SNMP_トラップ

 

jnxOvertemperature

1.3.6.1.4.1.2636.4.1.3

クリティカル

CHASSISD_ SNMP_トラップ

 

jnxFruRemoval

1.3.6.1.4.1.2636.4.1.5

通知

CHASSISD_ SNMP_トラップ

 

jnxFru挿入

1.3.6.1.4.1.2636.4.1.6

通知

CHASSISD_ SNMP_トラップ

 

jnxFruPowerOff

1.3.6.1.4.1.2636.4.1.7

通知

CHASSISD_ SNMP_トラップ

 

jnxFruPowerOn

1.3.6.1.4.1.2636.4.1.8

通知

CHASSISD_ SNMP_トラップ

 

jnxFru失敗しました

1.3.6.1.4.1.2636.4.1.9

警告

CHASSISD_ SNMP_トラップ

 

jnxFruオフライン

1.3.6.1.4.1.2636.4.1.10

通知

CHASSISD_ SNMP_トラップ

 

jnxFruOnline

1.3.6.1.4.1.2636.4.1.11

通知

CHASSISD_ SNMP_トラップ

 

jnxFruCheck

1.3.6.1.4.1.2636.4.1.12

通知

CHASSISD_ SNMP_トラップ

 

jnxPowerSupplyOK

1.3.6.1.4.1.2636.4.2.1

クリティカル

CHASSISD_ SNMP_トラップ

 

jnxFanOK

1.3.6.1.4.1.2636.4.2.2

クリティカル

CHASSISD_ SNMP_トラップ

 

jnx温度OK

1.3.6.1.4.1.2636.4.2.3

アラート

CHASSISD_ SNMP_トラップ

設定通知

構成管理 MIB (mib-jnx-cfgmgmt)

jnxCmCfgChange

1.3.6.1.4.1.2636.4.5.0.1

–

–

jnxCmRescue変更

1.3.6.1.4.1.2636.4.5.0.2

–

–

リモート操作通知

Ping MIB (mib-jnx-ping)

jnxPingRttしきい値を超えました

1.3.6.1.4.1.2636.4.9.0.1

–

–

jnxPingRttStdDevThreshold 超過

1.3.6.1.4.1.2636.4.9.0.2

–

–

jnxPingRttJitterThreshold 超過

1.3.6.1.4.1.2636.4.9.0.3

–

–

jnxPingEgressしきい値を超えました

1.3.6.1.4.1.2636.4.9.0.4

–

–

jnxPingEgressStdDevThreshold 超過

1.3.6.1.4.1.2636.4.9.0.5

–

–

jnxPingEgressJitterThreshold 超過

1.3.6.1.4.1.2636.4.9.0.6

–

–

jnxPingIngressThreshold 超過

1.3.6.1.4.1.2636.4.9.0.7

–

–

jnxPingIngressStddevしきい値を超えました

1.3.6.1.4.1.2636.4.9.0.8

–

–

jnxPingIngressJitterThreshold 超過

1.3.6.1.4.1.2636.4.9.0.9

–

–

RMONアラーム

RMON MIB (mib-jnx-rmon)

jnxRmonAlarmGetFailure

1.3.6.1.4.1.2636.4. 3.0.1

–

–

jnxRmonGetOk

1.3.6.1.4.1.2636.4. 3.0.2

–

–

QFabricシステムでサポートされるSNMPトラップ

QFabricシステムは、標準のSNMPv2トラップとジュニパーネットワークスエンタープライズ固有のSNMPv2トラップをサポートします。

注:

QFabricシステムは、SNMPv1トラップをサポートしていません。

詳細については、次を参照してください。

  • 標準SNMPv2トラップの表5

  • 表6:ジュニパーネットワークスエンタープライズ固有のSNMPv2トラップ

表5:QFabricシステムでサポートされる標準SNMPv2トラップ

定義

トラップ名

SNMPトラップOID

システムロギング重大度レベル

Syslogタグ

リンク通知

RFC 2863、 インターフェイスグループMIB

リンクダウン

1.3.6.1.6.3.1.1.5.3

警告

SNMP_TRAP_ LINK_DOWN

リンクアップ

1.3.6.1.6.3.1.1.5.4

情報

SNMP_TRAP_ LINK_UP

起動通知

RFC 1907、簡 易ネットワーク管理プロトコルバージョン2(SNMPv2)の管理情報ベース

コールドスタート

1.3.6.1.6.3.1.1.5.1

クリティカル

SNMPD_TRAP_ COLD_START

warmStart

1.3.6.1.6.3.1.1.5.2

エラー

SNMPD_TRAP_ WARM_START

認証失敗

1.3.6.1.6.3.1.1.5.5

通知

SNMPD_TRAP_ GEN_FAILURE

表6:QFabricシステムでサポートされるエンタープライズ固有のSNMPv2トラップ

ソースMIB

トラップ名

SNMPトラップOID

システムロギング重大度レベル

システムログタグ

ファブリックシャーシMIB (mib-jnx-fabric-chassis)

ファブリックシャーシ(アラーム状態)の通知

jnxFabric電源障害

1.3.6.1.4.1.2636.4.19.1

警告

–

jnxFabricFanFailure(英語)

1.3.6.1.4.1.2636.4.19.2

クリティカル

–

jnxFabricOvertemperature

1.3.6.1.4.1.2636.4.19.3

アラート

–

jnxFabric冗長スイッチオーバー

1.3.6.1.4.1.2636.4.19.4

通知

–

jnxFabricFruRemoval

1.3.6.1.4.1.2636.4.19.5

通知

–

jnxFabricFru挿入

1.3.6.1.4.1.2636.4.19.6

通知

–

jnxFabricFru電源オフ

1.3.6.1.4.1.2636.4.19.7

通知

–

jnxFabricFruPowerOn

1.3.6.1.4.1.2636.4.19.8

通知

–

jnxFabricFru失敗

1.3.6.1.4.1.2636.4.19.9

警告

–

jnxFabricFruオフライン

1.3.6.1.4.1.2636.4.19.10

通知

–

jnxFabricFruオンライン

1.3.6.1.4.1.2636.4.19.11

通知

–

jnxFabricFruCheck

1.3.6.1.4.1.2636.4.19.12

警告

–

jnxFabricFEBSwitchover

1.3.6.1.4.1.2636.4.19.13

警告

–

jnxFabricハードディスクに失敗しました

1.3.6.1.4.1.2636.4.19.14

警告

–

jnxFabricハードディスク欠落

1.3.6.1.4.1.2636.4.19.15

警告

–

jnxFabricBootFromBackup

1.3.6.1.4.1.2636.4.19.16

警告

–

ファブリックシャーシ(アラームクリア状態)通知

jnxFabric電源OK

1.3.6.1.4.1.2636.4.20.1

クリティカル

–

jnxFabricFanOK

1.3.6.1.4.1.2636.4.20.2

クリティカル

–

jnxFabricTemperatureOK

1.3.6.1.4.1.2636.4.20.3

アラート

–

jnxFabricFruOK

1.3.6.1.4.1.2636.4.20.4

–

–

QFabric MIB (mib-jnx-qf-smi)

QFabric MIB通知

jnxQFabricDownload発行済み

1.3.6.1.4.1.2636.3.42.1.0.1

–

–

jnxQFabricDownloadFailed(英語)

1.3.6.1.4.1.2636.3.42.1.0.2

–

–

jnxQFabricDownloadSucceeded

1.3.6.1.4.1.2636.3.42.1.0.3

–

–

jnxQFabricUpgrade発行済み

1.3.6.1.4.1.2636.3.42.1.0.4

–

–

jnxQFabricUpgradeFailed(英語)

1.3.6.1.4.1.2636.3.42.1.0.5

–

–

jnxQFabricUpgradeSucceeded

1.3.6.1.4.1.2636.3.42.1.0.6

–

–

設定通知

構成管理 MIB (mib-jnx-cfgmgmt)

jnxCmCfgChange

1.3.6.1.4.1.2636.4.5.0.1

–

–

jnxCmRescue変更

1.3.6.1.4.1.2636.4.5.0.2

–

–

リモート操作通知

Ping MIB (mib-jnx-ping)

jnxPingRttしきい値を超えました

1.3.6.1.4.1.2636.4.9.0.1

–

–

jnxPingRttStdDevThreshold 超過

1.3.6.1.4.1.2636.4.9.0.2

–

–

jnxPingRttJitterThreshold 超過

1.3.6.1.4.1.2636.4.9.0.3

–

–

jnxPingEgressしきい値を超えました

1.3.6.1.4.1.2636.4.9.0.4

–

–

jnxPingEgressStdDevThreshold 超過

1.3.6.1.4.1.2636.4.9.0.5

–

–

jnxPingEgressJitterThreshold 超過

1.3.6.1.4.1.2636.4.9.0.6

–

–

jnxPingIngressThreshold 超過

1.3.6.1.4.1.2636.4.9.0.7

–

–

jnxPingIngressStddevしきい値を超えました

1.3.6.1.4.1.2636.4.9.0.8

–

–

jnxPingIngressJitterThreshold 超過

1.3.6.1.4.1.2636.4.9.0.9

–

–

Junos OSでサポートされている標準SNMPトラップ

このトピックでは、Junos OSを実行するデバイスでサポートされている標準SNMPv1およびSNMPv2トラップのリストを紹介します。トラップの詳細については、 SNMP MIBエクスプローラを参照してください。

グレースフルルーティングエンジンスイッチオーバー(GRES)の後、新しいプライマリルーティングエンジンが1つのwarmStart通知を送信します。プライマリルーティングエンジンは、デバイスが立ち上がると coldStart 通知を送信します。プライマリルーティングエンジンは、その後のSNMPデーモン再起動の際に warmStart 通知も送信します。GRESの後、新しいプライマリルーティングエンジンは単一の warmStart 通知を送信し、バックアップルーティングエンジンは通知を送信しません。

標準SNMPバージョン1トラップ

表7は 、SNMPv1の標準トラップの概要を示しています。トラップは、まずトラップカテゴリ、次にトラップ名で整理され、企業ID、汎用トラップ番号、特定トラップ番号が含まれます。システムロギングの重大度レベルは、対応するシステムログタグを持つトラップに対してリストされています。対応するシステムロギング重大度レベルを持たないトラップには、表中で「-」が表示されています。

システムログメッセージの詳細については、 システムログエクスプローラを参照してください。

表7:標準でサポートされるSNMPバージョン1トラップ

定義

トラップ名

エンタープライズID

汎用トラップ番号

特定トラップ番号

システムロギング重大度レベル

Syslogタグ

サポート対象

起動通知

RFC 1215、 SNMPで使用するトラップを定義するための表記法

authenticationFailure

1.3.6.1.4.1.2636

4

0

通知

SNMPD_ TRAP_ GEN_FAILURE

Junos OSを実行しているすべてのデバイス。

coldStart

1.3.6.1.4.1.2636

0

0

クリティカル

SNMPD_TRAP_ COLD_START

Junos OSを実行しているすべてのデバイス。

warmStart

1.3.6.1.4.1.2636

1

0

エラー

SNMPD_TRAP_ WARM_START

Junos OSを実行しているすべてのデバイス。

リンク通知

RFC 1215、 SNMPで使用するトラップを定義するための表記法

linkDown

1.3.6.1.4.1.2636

2

0

警告

SNMP_ TRAP_ LINK_DOWN

Junos OSを実行しているすべてのデバイス。

linkUp

1.3.6.1.4.1.2636

3

0

情報

SNMP_TRAP_ LINK_UP

Junos OSを実行しているすべてのデバイス。

リモート操作通知

RFC 2925、 リモートPing、トレースルート、ルックアップ操作のためのマネージドオブジェクトの定義

pingProbeFailed

1.3.6.1.2.1.80.0

6

1

情報

SNMP_TRAP_PING_PROBE_失敗しました

Junos OSを実行しているすべてのデバイス。

pingTestFailed

1.3.6.1.2.1.80.0

6

2

情報

SNMP_TRAP_ PING_TEST _FAILED

Junos OSを実行しているすべてのデバイス。

pingTestCompleted

1.3.6.1.2.1.80.0

6

3

情報

SNMP_TRAP_ PING_TEST_完了しました

Junos OSを実行しているすべてのデバイス。

RMONアラーム

RFC 2819a、 RMON MIB

fallingAlarm

1.3.6.1.2.1.16

6

2

–

–

Junos OSを実行しているすべてのデバイス。

risingAlarm

1.3.6.1.2.1.16

6

1

–

–

Junos OSを実行しているすべてのデバイス。

ルーティング通知

BGP 4 MIB

bgpEstablished

1.3.6.1.2.1.15.7

6

1

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

bgpBackwardTransition

1.3.6.1.2.1.15.7

6

2

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

OSPFトラップMIB

ospfVirtIfStateChange

1.3.6.1.2.1.14.16.2

6

1

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfNbrStateChange

1.3.6.1.2.1.14.16.2

6

2

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2

6

3

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfIfConfigError

1.3.6.1.2.1.14.16.2

6

4

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2

6

5

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2

6

6

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2

6

7

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

8

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

9

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfTxRetransmit

1.3.6.1.2.1.14.16.2

6

10

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfVirtIfTxRetransmit

1.3.6.1.2.1.14.16.2

6

11

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2

6

13

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

ospfIfStateChange

1.3.6.1.2.1.14.16.2

6

16

–

–

MXおよびEXシリーズデバイス、およびSRXシリーズファイアウォール。

VRRP通知

RFC 2787、 仮想ルーター冗長性プロトコルの管理オブジェクト定義

vrrpTrapNewMaster

1.3.6.1.2.1.68

6

1

警告

VRRPD_NEW MASTER_TRAP

Junos OSを実行しているすべてのデバイス。

vrrpTrapAuthFailure

1.3.6.1.2.1.68

6

2

警告

VRRPD_AUTH_ FAILURE_TRAP

Junos OSを実行しているすべてのデバイス。

RFC 6527、 仮想ルーター冗長性プロトコルバージョン3(VRRPv3)の管理オブジェクトの定義

vrrpv3NewMaster

1.3.6.1.2.1.207

6

1

警告

VRRPD_NEW_MASTER

MXシリーズデバイス。

vrrpv3ProtoError

1.3.6.1.2.1.207

6

2

警告

VRRPD_V3_PROTO_ERROR

MXシリーズデバイス。

標準SNMPバージョン2トラップ

表8は 、Junos OSでサポートされている標準SNMPv2トラップの概要を示しています。トラップは、まずトラップカテゴリで、次にトラップ名で整理され、その snmpTrapOIDが含まれます。システムロギングの重大度レベルは、対応するシステムログタグを持つトラップに対してリストされています。対応するシステムロギング重大度レベルを持たないトラップには、表中で「 -」が表示されています。

表8:標準でサポートされるSNMPバージョン2トラップ

定義

トラップ名

snmpTrapOID

システムロギング重大度レベル

Syslogタグ

サポート対象

起動通知

RFC 1907、簡 易ネットワーク管理プロトコルバージョン2(SNMPv2)の管理情報ベース

coldStart

1.3.6.1.6.3.1.1.5.1

クリティカル

SNMPD_TRAP_ COLD_START

Junos OSを実行しているすべてのデバイス。

warmStart

1.3.6.1.6.3.1.1.5.2

エラー

SNMPD_TRAP_ WARM_START

Junos OSを実行しているすべてのデバイス。

authenticationFailure

1.3.6.1.6.3.1.1.5.5

通知

SNMPD_TRAP_ GEN_FAILURE

Junos OSを実行しているすべてのデバイス。

リンク通知

RFC 2863、 インターフェイスグループMIB

linkDown

1.3.6.1.6.3.1.1.5.3

警告

SNMP_TRAP_ LINK_DOWN

Junos OSを実行しているすべてのデバイス。

linkUp

1.3.6.1.6.3.1.1.5.4

情報

SNMP_TRAP_ LINK_UP

Junos OSを実行しているすべてのデバイス。

リモート操作通知

RFC 2925、 リモートPing、トレースルート、ルックアップ操作のためのマネージドオブジェクトの定義

pingProbeFailed

1.3.6.1.2.1.80.0.1

情報

SNMP_TRAP_ PING_PROBE_失敗しました

Junos OSを実行しているすべてのデバイス。

pingTestFailed

1.3.6.1.2.1.80.0.2

情報

SNMP_TRAP_PING_ TEST_FAILED

Junos OSを実行しているすべてのデバイス。

pingTestCompleted

1.3.6.1.2.1.80.0.3

情報

SNMP_TRAP_PING_ TEST_COMPLETED

Junos OSを実行しているすべてのデバイス。

RMONアラーム

RFC 2819a、 RMON MIB

fallingAlarm

1.3.6.1.2.1.16.0.1

–

–

Junos OSを実行しているすべてのデバイス。

risingAlarm

1.3.6.1.2.1.16.0.2

–

–

Junos OSを実行しているすべてのデバイス。

ルーティング通知

BGP 4 MIB

bgpEstablished

1.3.6.1.2.1.15.7.1

–

–

Junos OSを実行しているすべてのデバイス。

bgpBackwardTransition

1.3.6.1.2.1.15.7.2

–

–

Junos OSを実行しているすべてのデバイス。

OSPFトラップMIB

ospfVirtIfStateChange

1.3.6.1.2.1.14.16.2.1

–

–

Junos OSを実行しているすべてのデバイス。

ospfNbrStateChange

1.3.6.1.2.1.14.16.2.2

–

–

Junos OSを実行しているすべてのデバイス。

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2.3

–

–

Junos OSを実行しているすべてのデバイス。

ospfIfConfigError

1.3.6.1.2.1.14.16.2.4

–

–

Junos OSを実行しているすべてのデバイス。

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2.5

–

–

Junos OSを実行しているすべてのデバイス。

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2.6

–

–

Junos OSを実行しているすべてのデバイス。

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2.7

–

–

Junos OSを実行しているすべてのデバイス。

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2.8

–

–

Junos OSを実行しているすべてのデバイス。

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2.9

–

–

Junos OSを実行しているすべてのデバイス。

ospfTxRetransmit

1.3.6.1.2.1.14.16.2.10

–

–

Junos OSを実行しているすべてのデバイス。

ospfVirtIfTxRetransmit

1.3.6.1.2.1.14.16.2.11

–

–

Junos OSを実行しているすべてのデバイス。

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2.13

–

–

Junos OSを実行しているすべてのデバイス。

ospfIfStateChange

1.3.6.1.2.1.14.16.2.16

–

–

Junos OSを実行しているすべてのデバイス。

MPLS通知

RFC 3812、 MPLS(MPLS)トラフィックエンジニアリング(TE)管理情報ベース

mplsTunnelUp

mplsTunnelDown

mplsTunnelRerouted

mplsTunnelReoptimized

エンティティ状態 MIB 通知

RFC 4268、 エンティティ状態MIB

entStateOperEnabled

1.3.6.1.2.1.131.0.1

通知

CHASSISD_SNMP_TRAP3

MX240、MX480、およびMX960

entStateOperDisabled

1.3.6.1.2.1.131.0.2

通知

CHASSISD_SNMP_TRAP3

MX240、MX480、およびMX960

L3VPN通知

RFC 4382、 MPLS/BGPレイヤー3仮想プライベートネットワーク(VPN)

mplsL3VpnVrfUp

mplsL3VpnVrfDown

mplsL3VpnVrf RouteMidThresh Exceeded

mplsL3VpnVrf NumVrfRouteMax ThreshExceeded

mplsL3VpnNum VrfRouteMax ThreshCleared

VRRP通知

RFC 2787、 仮想ルーター冗長性プロトコルの管理オブジェクト定義

vrrpTrapNewMaster

1.3.6.1.2.1.68.0.1

警告

VRRPD_ NEWMASTER_トラップ

Junos OSを実行しているすべてのデバイス。

vrrpTrapAuthFailure

1.3.6.1.2.1.68.0.2

警告

VRRPD_AUTH_ FAILURE_トラップ

Junos OSを実行しているすべてのデバイス。

RFC 6527、 仮想ルーター冗長性プロトコルバージョン3(VRRPv3)の管理オブジェクトの定義

vrrpv3NewMaster

1.3.6.1.2.1.207.0.1

警告

VRRPD_NEW_MASTER

MXシリーズデバイス。

vrrpv3ProtoError

1.3.6.1.2.1.207.0.2

警告

VRRPD_V3_PROTO_ERROR

MXシリーズデバイス。

Syslogトラップ用にカスタマイズされたSNMP MIB

SNMP syslog トラップは、リモートの SNMP 対応デバイスから中央のコレクターに送信される警告メッセージで、コンポーネントに障害が発生した場合や、重要なリソースが設定可能な限界を超えた場合に通知します。この情報は、MIB(管理情報ベース)でキャプチャされます。ジュニパーネットワークスエンタープライズ固有のシステムログMIBにより、重要なシステムログメッセージが発生した場合に、SNMPトラップベースのアプリケーションの通知が可能になります。MIBは、syslogエントリをジェネリックjnxSyslogTrap OIDにマッピングするように定義されています。

jnxSyslogTrap OID は、syslog で生成されたログを基にしたトラップです。イベントプロセス(eventd)はsyslogを監視し、syslogイベントのイベントポリシー raise-trap 設定ステートメントに基づいて、すべてのsyslogイベントを1つのジェネリックsyslog定義トラップMIBに送信します。これがjnxSyslogTrapです。

ジェネリック MIB OID を 1 つ使用すると、同じ OID を持つアラームを区別することができないため、特定のイベントを検出するために syslog トラップ OID 値を処理したいユーザーには不便です。しかし、Junos OSリリース18.3R1では、カスタムOIDを特定のログにマッピングし、デバイス上に動的にロードすることができます。

この機能のメリットは、異なるタイプのsyslogイベントに特定のOIDを割り当てる方法があるため、異なるタイプのsyslogイベントを効果的に監視できることです。

カスタムSNMP MIBの概要

syslogトラップ用のカスタムSNMP MIBを作成するには、以下のタスクを完了する必要があります。

  • カスタム MIB を作成します。

  • MIBファイルをYANGフォーマットに変換し、YANGファイルをデバイスにコピーします。

  • YANGファイルをデバイスにロードします。

以下のセクションでは、これらの手順の概要を説明します。

MIBファイルの作成

特定のログをカスタム OID でマッピングできるようになる前に、カスタム MIB を作成する必要があります。コリジョンを避けるために、MIBオブジェクトとトラップは、 表9に示す予約済みルートでのみ定義する必要があります。

表9:カスタムMIBモジュールのMIBルート MIB

ルート

説明

OID

.iso.org.dod.internet.private.enterprises.juniperMIB.jnxMibs.jnxCustomMibRoot

カスタム MIB モジュール

.1.3.6.1.4.1.2636.3.86

.iso.org.dod.internet.private.enterprises.juniperMIB.jnxTraps.jnxCustomSyslogNotifications

カスタムトラップ通知

.1.3.6.1.4.1.2636.4.30

YANG ファイルへの変換

MIB 定義をデバイスにロードする前に、MIB ファイルを YANG フォーマットに変換する必要があります。MIBファイルをYANGに変換するには、smidump v0.5.0ツールを使用することをお勧めします。smidumpツールは、ラップトップにインストールできるオープンソースアプリケーションです( https://www.ibr.cs.tu-bs.de/projects/libsmi/smidump.html を参照)。

ファイルが YANG フォーマットに変換されたら、デバイスにコピーする必要があります。次に、CLIコマンドを使用して、SNMPプロセス(snmpd)にロードします。その後、対応するJSONファイルが生成され、snmpdがこのファイルを解析して、そこからOID階層のデータベースを構築します。不明なタグが見つかった場合、snmpd は適切なエラーメッセージを返します。

YANG ファイルの管理に使用する CLI コマンド

YANG モジュールをsnmpdにロードするには、request system yang addコマンドでsnmpオプションを使用します。

yang-filenameには、絶対パスが含まれます。

注:

request system yang addコマンドを実行するには、スーパーユーザーアクセスが必要です。

デバイス上の YANG ファイルを管理するコマンドは他に、 show system yang package と request system yang delete の 2 つです。

Syslogトラップ用のカスタムMIBを定義する

この手順では、次のサンプル ファイルを使用します。

  • 変換するMIBファイル

  • 出力

注:

YANG は、このドキュメントで提供されている YANG の例を参照することで手動で記述できますが、smidump ツール v0.5.0 を使用して MIB を YANG 形式に変換することをお勧めします。

syslogトラップのカスタムMIBを定義するには:

  1. MIBをネットワーク管理システム(NMS)にロードし、エラーがないか確認します。
  2. 次のコマンドを使用してsmidumpツールを呼び出します。ここで、 dependency-mib、 input-custom-mib-file、および YANG-MODULE-NAME は特定のファイル名の変数です。

    次に例を示します。

    出力として、変換されたYANGファイルJUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB.yangを取得します。

    入力カスタムMIBファイルの mib-jnx-example-custom-syslog.txt は、SNMPv2-SMI、JUNIPER-SMI、IF-MIBに依存していることに注意してください。しかし、SNMPv2-SMIとIF-MIBは標準MIBであるため、その定義はすでにsmidumpに存在しています。したがって、必要な依存MIBファイルは、モジュールJUNIPER-SMI定義を持つ mib-jnx-smi.txtのみです。

  3. JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB.yangファイルをデバイス上の任意のパスにコピーし、依存するすべてのYANGファイルを次のパスにあるデバイスにコピーします:/opt/lib/python2.7/site-packages/pyang/modules。
    注:

    依存するすべての MIB を YANG ファイルに変換し、これらをデバイスにコピーする必要があります。

    YANGモジュールに変換され、上記のパスに存在する標準MIBの一部を次に示します: IANAifType-MIB.yang、 ietf-yang-types.yang、 ietf-inet-types.yang、 IF-MIB.yang、 JUNIPER-SMI.yang、 SNMPv2-TC.yang。

  4. CLIを使用して、次のコマンドを使用してYANGモジュールをsnmpdにロードします。

    次に例を示します。

    YANG モジュールは JSON 形式に変換され、内部データベースの解析と作成のために snmpd に移動します。

  5. 新たに追加されたトラップ定義を含むsyslogに基づくトラップが機能していることを確認するには、トラップをスプーフィング(模倣)します。これは、CLIまたはイベントポリシーを使用して行うことができます。以下は、CLIを使用してトラップをスプーフィングする例です。

mib-jnx-example-custom-syslog.txt

JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB.YANG

カスタムSNMPトラップを使用する際の制限

頻繁に発生するsyslogのトラップをトリガーしないように、イベントスクリプトを作成するように注意してください。この方法により、デバイスに負荷がかからないようにできます。

アクセス タイプが readonly または readwrite のオブジェクトを追加した場合、そのオブジェクトは snmpget や snmpwalk などの snmp ポーリング操作でポーリングに使用できず、アクセス タイプ notifyonly として扱われます。これは、この機能がデバイスに動的なTRAP OID定義を追加するためのものであり、これによりお客様はスクリプトを作成して各syslogにカスタムトラップを送信することができます。アクセス タイプ readonly と readwrite は SNMP ポーリング用で、 notifyonly はトラップ用です。

カスタムMIBの場合、カスタムテーブルの定義はサポートされていません。テーブルオブジェクトを持つトラップをvarbindとして送信する場合は、カスタムMIBでカスタムテーブルを定義するのではなく、Junos MIBで定義済みのテーブルを使用します。

YANGファイルは、すべてのシャーシノードとルーティングエンジンに個別に読み込む必要があります。 request system yang add コマンドを実行しても、バックアップルーティングエンジンに自動的にコピーされることはありません。

カスタムSyslogトラップの例

このカスタム syslog トラップの例は、次のいずれかが発生した場合に、運用担当者がトラップを受信したいユースケースを示しています。

  • ユーザーがCLIで設定モードに入ります(イベントは ui_dbase_login_eventとして定義されます)

  • ユーザーがコミットを実行します(イベントは次のように定義されます ui_commit)

カスタムsyslogトラップ機能がサポートされる前は、両方のイベントで固定OIDを持つjnxSyslogTrapを使用するしかありませんでした。カスタムsyslogトラップ機能を使用すると、カスタム定義のOIDを持つトラップを生成できるようになりました。

カスタムsyslogトラップを定義するには:

  1. 提供されたサンプル ファイルを使用して JUNIPER-EXAMPLE-CUSTOM-SYSLOIG-MIB.yang に変換します。
  2. YANGファイルをデバイスにコピーします。
  3. SNMP YANG ファイルを読み込みます。
  4. slaxスクリプトを /var/db/scripts/event にコピーして、トラップを偽装します。

    ui_dbase_login_eventには、ユーザー名がvarbindのenteredConfigModeトラップを設定します。

    ui_commitには、ユーザー名コマンドのコメントを持つconfigCommittedトラップを3つのvarbindとして設定します。

  5. トラップを設定します。
  6. snmpd traceoptionsとトラップターゲットを有効にして、送信されたトラップを検証します。
  7. トラップが動作していることを確認します。

サンプル MIB ファイル

YANG 変換ファイルのサンプル

slax スクリプト cutom_trap.slax (/var/db/scripts/event 内)

プラットフォーム固有のSNMPトラップの動作

機能エクスプローラーを使用して、特定の機能のプラットフォームとリリースのサポートを確認します。

お使いのプラットフォームに固有の動作を確認するには、以下の表を使用してください。

プラットフォーム 違い

EXシリーズ

  • SNMPトラップをサポートするEXシリーズスイッチは、CPU温度を監視するセンサーからのみフレキシブルPICコンセントレータ(FPC)用の過熱SNMPトラップを生成しますが、同じスイッチはすべてのセンサーからコントロールボード(CB)用の過熱SNMPトラップを生成します。

変更履歴テーブル

サポートされる機能は、使用しているプラットフォームとリリースによって決まります。 機能エクスプローラー を使用して、機能がお使いのプラットフォームでサポートされているかどうかを確認します。

リリース
説明
20.1R1
Junos OSリリース20.1以降では、グレースフルルーティングエンジンスイッチオーバー(GRES)の後、新しいプライマリルーティングエンジンがwarmStart通知を1つ送信します。