Standards pris en charge pour le Segment Routing
Découvrez les RFC de Segment Routing et les brouillons Internet pris en charge par Junos OS.
Cette rubrique répertorie les RFC de Segment Routing et les brouillons Internet que Junos OS prend, partiellement ou ne prend pas en charge. Il identifie également les RFC que l’IETF classe comme expérimentaux ou informationnels.
RFC et brouillons Internet pris en charge
Junos OS prend en charge les RFC de Segment Routing et les brouillons Internet suivants.
RFC pris en charge
-
RFC 5286, Spécification de base pour le reroutage rapide IP : alternatives sans boucle
-
RFC 7471, Extensions de métriques OSPF Traffic Engineering (TE)
-
RFC 7490, Reroutage rapide (FRR) LFA (Remote Loop-Free Alternate)
-
RFC 7684, Annonce du préfixe/attribut de lien OSPFv2
-
RFC 7752, Distribution vers le nord des informations d’ingénierie d’état de lien et de trafic (TE) à l’aide de BGP
-
RFC 7855, Énoncé du problème et exigences SPRING (Source Packet Routing in Networking)
-
RFC 8102, Protection et gestion des nœuds Remote-LFA
-
RFC 8277, Utilisation de BGP pour lier des étiquettes MPLS à des préfixes d’adresses
-
RFC 8287, LSP Ping/Traceroute pour le Segment Routing
-
RFC 8403, un système de surveillance du plan de données MPLS évolutif et conscient de la topologie
-
RFC 8426, coexistence RSVP-SR
-
RFC 8571, BGP - Annonce de l’état des liens (BGP-LS) des extensions de métriques de performance de l’ingénierie de trafic IGP
-
RFC 8604, Interconnexion de millions de points de terminaison grâce au Segment Routing
-
RFC 8660, Segment Routing with the MPLS Data Plane
-
RFC 8661, Interfonctionnement MPLS de Segment Routing avec LDP
-
RFC 8665, Extensions OSPF pour le Segment Routing
-
RFC 8690, Clarification de la longueur sous-TLV de l’ID de segment pour RFC 8287
-
RFC 8986, Programmation réseau Segment Routing over IPv6 (SRv6)
-
RFC 9085, Border Gateway Protocol - Extensions d’état de lien (BGP-LS) pour le Segment Routing
-
RFC 9086, Border Gateway Protocol - Extensions d’état de lien (BGP-LS) pour le Segment Routing Peer Engineering de sortie BGP
-
RFC 9256, Architecture de stratégie de Segment Routing
-
RFC 9252, services de superposition BGP basés sur le Segment Routing sur IPv6 (SRv6)
-
RFC 9350, algorithme flexible IGP
-
RFC 9800, Compressed SRv6 Segment List Encoding (prise en charge partielle). Nous ne prenons en charge que les micro-SID SRv6.
-
RFC 9819, Signal d’argument pour les services BGP dans le Segment Routing over IPv6 (SRv6)
Brouillons Internet pris en charge
-
draft-agrawal-spring-srv6-mpls-interworking-06, interfonctionnement SRv6 et MPLS
Prend en charge l’interopérabilité des services.
-
draft-bashandy-rtgwg-segment-routing-ti-lfa, Reroutage rapide indépendant de la topologie à l’aide du Segment Routing
-
draft-bashandy-rtgwg-segment-routing-uloop, Évitement des microboucles à l’aide du Segment Routing
-
draft-filsfils-rtgwg-segment-routing-use-cases-02, cas d’usage de Segment Routing
-
draft-filsfils-spring-sr-policy-considerations-05, Considérations relatives à la mise en œuvre et au déploiement de la politique SR
-
draft-filsfils-spring-sr-traffic-counters, compteurs de trafic SR
-
draft-ietf-idr-bgp-prefix-sid, Annoncer un segment BGP pour un préfixe BGP
-
draft-ietf-idr-bgpls-segment-routing-epe, extensions BGP-LS pour l’ingénierie de trafic pair sortant à l’aide de SR
-
draft-ietf-idr-segment-routing-te-policy, Annoncez les stratégies SR-TE via BGP
-
draft-ietf-idr-segment-routing-te-policy-09, Stratégies de Segment Routing publicitaires dans BGP
-
draft-ietf-lsr-isis-srv6-extensions, extensions IS-IS pour prendre en charge le Segment Routing sur le plan de données IPv6
-
draft-ietf-ospf-segment-routing-extensions, extensions OSPF pour distribuer des segments SR
-
draft-ietf-pce-segment-routing, extensions PCE pour configurer un chemin SR-TE à partir du contrôleur (vers le sud)
-
draft-ietf-is-segment-routing-extensions, extensions IS-IS pour distribuer des segments SR
-
draft-ietf-rtgwg-segment-routing-ti-lfa-04, Reroutage rapide indépendant de la topologie à l’aide du Segment Routing
-
draft-ietf-spring-conflict-resolution, Segment Routing, résolution de conflit MPLS
-
draft-ietf-spring-resiliency-use-cases, cas d’utilisation de la résilience dans les réseaux SPRING
-
draft-ietf-spring-segment-routing-central-epe, SR Ingénierie centralisée des pairs de sortie BGP
-
draft-ietf-spring-segment-routing-mpls, détails du Segment Routing avec transfert MPLS
-
draft-ietf-spring-segment-routing-policy-07.txt, Segment Routing Policy Architecture
-
draft-kaliraj-idr-bgp-classful-transport-planes-12, plans de transport de classe BGP
-
draft-ali-6man-srv6-vpn-icmp-error-handling-00 Gestion des erreurs ICMP dans les réseaux VPN basés sur SRv6
RFC et brouillons Internet partiellement pris en charge
Junos OS prend partiellement en charge les RFC de Segment Routing et les brouillons Internet suivants.
RFC partiellement pris en charge
-
RFC 4971, Extensions IS-IS (Intermediate System to Intermediate System) pour les informations sur les routeurs publicitaires (prise en charge partielle)
-
RFC 8402, Architecture de Segment Routing (prise en charge partielle)
-
RFC 8570, Extensions de métriques d’ingénierie de trafic (TE) IS-IS (prise en charge partielle)
Prend en charge les paramètres liés au délai de liaison.
-
RFC 8663, MPLS Segment Routing over IP (prise en charge partielle)
-
RFC 8919, Attributs de liens spécifiques aux applications IS-IS (prise en charge partielle)
-
RFC 9862, Extensions PCEP (Path Computation Element Communication Protocol) pour les chemins candidats à la stratégie de Segment Routing (SR)
Il existe un écart mineur dans la gestion du TLV SRPOLICY-CAPABILITY. L’implémentation suit la spécification draft-ietf-pce-segment-routing-policy-cp-05, qui n’impose pas le TLV SRPOLICY-CAPABILITY dans l’objet PCEP Open. Par conséquent, le PCC n’annonce pas ce TLV, ce qui entraîne l’échec de l’établissement de la session PCEP avec des pairs appliquant strictement la RFC 9862. Si un haut-parleur PCEP reçoit un objet SRPA sans échange TLV préalable, il doit envoyer un message PCErr (Error-Type=10 « Reception of an invalid object » and Error-value=44 « Missing SRPOLICY-CAPABILITY TLV ») et mettre fin à la session.
-
RFC 9603, Extensions PCEP (Path Computation Element Communication Protocol) pour IPv6 Segment Routing
-
Junos OS définit toujours le bit N sur 0 dans le message PCEP Open.
-
Le client PCC (Path Computation Client) et le routage de segments-ingénierie du trafic (SR-TE) ne peuvent pas résoudre un identifiant d’accès réseau (NAI) en identifiant de segment (SID) SRv6.
-
SR-TE ne vérifie pas les SID dans l’objet de route explicite (ERO), y compris lorsque le bit V est défini sur 1.
-
Brouillons Internet partiellement pris en charge
-
draft-ali-spring-sr-traffic-accounting, comptabilité matricielle du trafic SR (prise en charge partielle)
Prend uniquement en charge le compteur.
-
draft-ginsberg-isis-prefix-attributes, attributs de préfixe IS-IS pour accessibilité IPv4 et IPv6 étendue (prise en charge partielle)
-
draft-ietf-spring-ipv6-use-cases, Cas d’utilisation du routage de paquets sources IPv6 dans les réseaux (prise en charge partielle)
-
draft-ietf-spring-segment-routing-msdc, segment de préfixe BGP dans les datacenters à grande échelle (prise en charge partielle)
-
draft-ietf-spring-segment-routing-policy, politique SR pour TE (prise en charge partielle)
-
draft-xu-mpls-sr-over-ip, MPLS Segment Routing over IP (prise en charge partielle)
RFC expérimentaux et informationnels
Les RFC suivants ne définissent pas de normes, mais fournissent des informations sur le Segment Routing et les technologies associées. L’IETF classe ces RFC différemment comme « expérimentaux » ou « informationnels ».
-
RFC 6571, Applicabilité des alternatives sans boucles (LFA) dans les réseaux de fournisseurs de services (SP)
-
RFC 9087, Segment Routing Centralized BGP Egress Peer Engineering
RFC non pris en charge
Les RFC de Segment Routing et les brouillons Internet suivants ne sont pas pris en charge par Junos OS.
-
RFC 5642, Mécanisme dynamique d’échange de noms d’hôte pour OSPF
-
RFC 8668, Attributs de liaison des membres du lot de couche 2 publicitaires dans IS-IS
L’implémentation prend en charge l’attribution statique d’étiquettes MPLS pour les liens membres, car la publication IS-IS de ces étiquettes n’est pas prise en charge.
-
RFC 9871, Routage sensible aux couleurs (CAR) BGP
-
RFC 9960, Politique de Segment Routing point à multipoint
-
RFC 9524, Réplication de Segment Routing pour la prestation de services multipoints