创建路由实例
-
如果您有网络的配置文件,则可以使用文件>导入数据菜单导入配置文件以创建网络模型,如 路由器数据提取概述中所述。接口将自动与它们所属的路由实例或进程 ID 相关联。
对于瞻博网络路由器,将为 [edit routing-instances routing-instance-name] 块下列出的接口分配该 routing-instance-name。同样,对于 Cisco 路由器,将为在“路由器 ospf <processID>”块的网络语句下播发地址的接口分配该 processID。
请注意,如果接口未启用 OSPF,则在加载网络时,该接口将被分配到名为“NOPROT”的保留类别。同样,如果接口启用了 OSPF,但没有进程 ID,则在加载网络时,它将被分配到名为“NOID”的保留类别。
要查看路由实例与接口的关联,请选择“ 网络>元素”>“接口...选择接口时,底部窗格的 Advanced 选项卡将在 OSPF PID 字段中显示进程 ID/路由实例。要将路由实例作为表的列进行查看,请右键单击标题行并选择 “表选项...然后,将 OSPF PID 从“可用项目”列表添加到“所选项目”列表中。
-
OSPF 进程 ID (PID) 或路由实例名称也可以通过“修改接口”窗口的“高级”选项卡与接口相关联,以进行假设测试,如 图 1 所示。要访问此窗口,请单击“修改操作模式”按钮以切换到“修改”模式,然后选择 “修改>元素>接口”。然后选择要修改的接口,然后单击“ 修改”。Cisco 路由器上的 OSPF 进程是一个整数,而瞻博网络路由器上的 OSPF 进程通常是一个名称。
图 1:修改接口窗口
-
默认情况下,多进程检查处于关闭状态。要打开布线实例分析的多过程检查,请选择“设计”>“路径放置选项”窗格>“工具选项”,并将右下角的“忽略多过程”设置为“False”。或者,您可以将参数 ignoremultiprocess=0 添加到项目的 dparam。runcode 文件。要默认为所有新网络项目打开多进程检查,请创建或编辑文件 /u/wandl/db/misc/dparam.txt 并添加“ignoremultiprocess=0”行。
-
要通过将路由实例/OSPF PID 与颜色关联在一起来在地图上可视化它们,您可以在规范文件中指定 routeinstance 文件,如第 214 页的文件格式中所示,方法是在网络关闭时将条目“routeinst= filename”添加到规范文件中,用路由实例定义文件的名称替换 filename 。还可以在配置文件导入 (File>Import) 期间通过在导入网络向导的 Misc 选项卡上指定 RouteInstance 文件来指示此文件。或者,也可在修改模式下,从主菜单中选择修改>协议>OSPF/IS-IS路由实例,从而为当前网络会话建立关联。
图 2:路由实例窗口
-
单击“添加”按钮,将出现一个新窗口,如 图 3 所示。
图 3:添加路由实例窗口
-
输入路由实例名称。然后,为应映射到此路由实例的每个 OSPF 进程 ID(对于思科)或路由实例名称(对于瞻博网络)单击添加行。
字段
描述
路由实例名称
用于识别分区网络的名称。
路由实例多样性
当前未使用
路由实例公共组字符串
社区字符串用于 BGP 下一跃点检查,以确保 BGP 下一跃点位于所需的路由实例中
OSPF PID
属于此路由实例的 OSPF 进程 ID 和名称。同一个 OSPF PID 不能在多个路由实例中使用。
-
通过路由实例文件或修改>协议>OSPF/IS-IS路由实例菜单定义路由实例后,还可以通过修改链接窗口(可通过修改>元素>链接访问)将链路与路由实例相关联,如 图 4 所示。但是,如果连接到链路的接口也与“修改>元素>接口”窗口中的路由实例相关联,则此设置将被覆盖。链路两端的接口应属于同一个路由实例。
图 4:修改链接窗口
-
如果在拓扑图中选择 “子视图”>“布线实例”(Subviews Routing Instances ),则将使用为相应布线实例指定的颜色显示链接。
图 5:拓扑图 - 路由实例
您可以切换路由实例旁边的复选标记,以打开或关闭接口定义为位于该路由实例中的链路的显示。此外,您还可以通过单击路径实例名称旁边的颜色框来修改与地图上路径实例关联的颜色。