Junos OS 支持的 SNMP 陷阱

网络设备和系统支持标准 SNMP 陷阱以及特定于企业的陷阱。

使用 功能资源管理器 确认平台和版本对特定功能的支持。

查看 特定于平台的 SNMP 陷阱行为 部分,了解与您的平台相关的说明。

QFX 系列独立交换机、QFX 系列虚拟机箱和 QFabric 系统支持 SNMP 陷阱

QFX 系列独立交换机和 QFX 系列虚拟机箱支持 SNMP 陷阱

QFX 系列独立交换机和 QFX 系列虚拟机箱支持 SNMPv1 和 SNMPv2 陷阱。有关详细信息,请参阅:

SNMPv1 陷阱

QFX 系列独立交换机和 QFX 系列虚拟机箱支持标准 SNMPv1 陷阱和瞻博网络企业专用 SNMPv1 陷阱。请参阅:

  • 标准 SNMPv1 陷阱的表 1。

  • 表 2 显示特定于企业的 SNMPv1 陷阱。

陷阱首先按陷阱类别组织,然后按陷阱名称组织。为具有这些严重性级别的陷阱列出了系统日志记录严重性级别。没有相应系统日志记录严重性级别的陷阱用破 折号 (–) 标记。

表 1:QFX 系列独立交换机和QFX 系列虚拟机箱支持的标准 SNMP 版本 1 陷阱

定义于

陷阱名称

企业 ID

通用陷阱编号

特定陷阱编号

系统日志记录严重性级别

系统日志标记

链接通知

RFC 1215, 用于定义用于 SNMP 的陷阱的约定

链路向下

1.3.6.1.4.1.2636

2

0

警告

SNMP_ TRAP_ LINK_DOWN

链接

1.3.6.1.4.1.2636

3

0

信息

SNMP_TRAP_ LINK_UP

远程操作通知

RFC 2925, 用于远程 Ping、Traceroute 和查找操作的托管对象的定义

pingProbeFailed

1.3.6.1.2.1.80.0

6

1

信息

SNMP_TRAP _PING_ PROBE_失败

pingTest失败

1.3.6.1.2.1.80.0

6

2

信息

SNMP_TRAP_ PING_TEST _FAILED

pingTest已完成

1.3.6.1.2.1.80.0

6

3

信息

SNMP_TRAP_ PING_TEST_已完成

traceRoutePathChange

1.3.6.1.2.1.81.0

6

1

信息

SNMP_TRAP_ TRACE_ROUTE_ PATH_CHANGE

traceRouteTestFailed

1.3.6.1.2.1.81.0

6

2

信息

SNMP_TRAP_ TRACE_ROUTE_ TEST_FAILED

traceRouteTestCompleted(跟踪路由测试已完成)

1.3.6.1.2.1.81.0

6

3

信息

SNMP_TRAP_ TRACE_ROUTE_ TEST_COMPLETED

RMON 报警

RFC 2819a,RMON MIB

fallingAlarm

1.3.6.1.2.1.16

6

2

–

–

上升报警

1.3.6.1.2.1.16

6

1

–

–

路由通知

BGP 4 MIB

bgp已建立

1.3.6.1.2.1.15.7

6

1

–

–

bgp向后过渡

1.3.6.1.2.1.15.7

6

2

–

–

OSPF 陷阱 MIB

ospfVirtIf状态更改

1.3.6.1.2.1.14.16.2

6

1

–

–

ospfNbr状态更改

1.3.6.1.2.1.14.16.2

6

2

–

–

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2

6

3

–

–

ospfIfConfigError

1.3.6.1.2.1.14.16.2

6

4

–

–

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2

6

5

–

–

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2

6

6

–

–

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2

6

7

–

–

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

8

–

–

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

9

–

–

ospfTx重传

1.3.6.1.2.1.14.16.2

6

10

–

–

ospfVirtIfTx重传

1.3.6.1.2.1.14.16.2

6

11

–

–

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2

6

13

–

–

ospfIfStateChange

1.3.6.1.2.1.14.16.2

6

16

–

–

启动通知

RFC 1215, 用于定义用于 SNMP 的陷阱的约定

认证失败

1.3.6.1.4.1.2636

4

0

注意

SNMPD_ TRAP_ GEN_FAILURE

冷启动

1.3.6.1.4.1.2636

0

0

严重

SNMPD_TRAP_ COLD_START

暖启动

1.3.6.1.4.1.2636

1

0

错误

SNMPD_TRAP_ WARM_START

VRRP 通知

RFC 2787, 虚拟路由器冗余协议托管对象的定义

vrrp陷阱新主

1.3.6.1.2.1.68

6

1

警告

VRRPD_NEW MASTER_TRAP

vrrpTrapAuthFailure

1.3.6.1.2.1.68

6

2

警告

VRRPD_AUTH_ FAILURE_TRAP

表 2:QFX 系列独立交换机和 QFX 系列虚拟机箱上支持的企业特定 SNMPv1 陷阱

定义于

陷阱名称

企业 ID

通用陷阱编号

特定陷阱编号

系统日志记录严重性级别

系统日志标记

机箱通知(报警情况)

机箱 MIB (jnx-chassis. MIB)

jnx电源故障

1.3.6.1.4.1.2636.4.1

6

1

警告

CHASSISD_ SNMP_陷阱

jnxFanFailure

1.3.6.1.4.1.26361

6

2

严重

CHASSISD_ SNMP_陷阱

jnx过温

11.4.1.2636.4.1

6

3

警报

CHASSISD_ SNMP_陷阱

jnxFruRemoval

1.3.6.1.4.1.2636.4.1

6

5

注意

CHASSISD_ SNMP_陷阱

jnxFru插入

1.3.6.1.4.1.2636.4.1

6

6

注意

CHASSISD_ SNMP_陷阱

jnxFru断电

1.3.6.1.4.1.2636.4.1

6

7

注意

CHASSISD_ SNMP_陷阱

jnxFruPowerOn

1.3.6.1.4.1.2636.4.1

6

8

注意

CHASSISD_ SNMP_陷阱

jnxFruFailed

1.3.6.1.4.1.2636.4.1

6

9

警告

CHASSISD_ SNMP_陷阱

jnxFru离线

1.3.6.1.4.1.2636.4.1

6

10

注意

CHASSISD_ SNMP_陷阱

jnxFru在线

1.3.6.1.4.1.2636.4.1

6

11

注意

CHASSISD_ SNMP_陷阱

jnxFruCheck

1.3.6.1.4.1.2636.4.1

6

12

警告

CHASSISD_ SNMP_陷阱

jnx电源确定

1.3.6.1.4.1.2636.4.2

6

1

严重

CHASSISD_ SNMP_陷阱

jnxFanOK

1.3.6.1.4.1.2636.4.2

6

2

严重

CHASSISD_ SNMP_陷阱

jnx温度正常

1.3.6.1.4.1.2636.4.2

6

3

警报

CHASSISD_ SNMP_陷阱

配置通知

配置管理 MIB (jnx- configmgmt. MIB)

jnxCmCfgChange

1.3.6.1.4.1.2636.4.5

6

1

–

–

jnxCmRescueChange

1.3.6.1.4.1.2636.4.5

6

2

–

–

远程操作

ping MIB (jnx-ping.mib)

jnxPingRttThreshold 超出

1.3.6.1.4.1.2636.4.9

6

1

–

–

jnxPingRttStdDevThreshold 超出

1.3.6.1.4.1.2636.4.9

6

2

–

–

jnxPingRttJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9

6

3

–

–

jnxPingEgressThreshold 超出

1.3.6.1.4.1.2636.4.9

6

4

–

–

jnxPingEgressStdDev 阈值超出

1.3.6.1.4.1.2636.4.9

6

5

–

–

jnxPingEgressJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9

6

6

–

–

jnxPingIngressThreshold 已超出

1.3.6.1.4.1.2636.4.9

6

7

–

–

jnxPingIngressStddevThreshold 超出

1.3.6.1.4.1.2636.4.9

6

8

–

–

jnxPingIngressJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9

6

9

–

–

RMON 报警

RMON MIB (jnx-rmon. MIB)

jnxRmonAlarmGetFailure

1.3.6.1.4.1.2636.4.3

6

1

–

–

jnxRmonGetOk

1.3.6.1.4.1.2636.4.3

6

2

–

–

SNMPv2 陷阱

  • 表 3 列出了标准 SNMP 陷阱

  • 表 4 列出了瞻博网络企业特定的陷阱

表 3:QFX 系列独立交换机和 QFX 系列虚拟机箱支持的标准 SNMPv2 陷阱

定义于

陷阱名称

SNMP 陷阱 OID

系统日志记录严重性级别

系统日志标记

链接通知

RFC 2863, 接口组 MIB

链路向下

1.3.6.1.6.3.1.1.5.3

警告

SNMP_TRAP_ LINK_DOWN

链接

1.3.6.1.6.3.1.1.5.4

信息

SNMP_TRAP_ LINK_UP

远程操作通知

RFC 2925, 用于远程 Ping、Traceroute 和查找操作的托管对象的定义

pingProbeFailed

1.3.6.1.2.1.80.0.1

信息

SNMP_TRAP_ PING_PROBE_失败

pingTest失败

1.3.6.1.2.1.80.0.2

信息

SNMP_TRAP_PING_ TEST_FAILED

pingTest已完成

1.3.6.1.2.1.80.0.3

信息

SNMP_TRAP_PING_ TEST_COMPLETED

traceRoutePathChange

1.3.6.1.2.1.81.0.1

信息

SNMP_TRAP_TRACE_ ROUTE_PATH_变更

traceRouteTestFailed

1.3.6.1.2.1.81.0.2

信息

SNMP_TRAP_TRACE_ ROUTE_TEST_FAILED

traceRouteTestCompleted(跟踪路由测试已完成)

1.3.6.1.2.1.81.0.3

信息

SNMP_TRAP_TRACE_ ROUTE_TEST_已完成

RMON 报警

RFC 2819a,RMON MIB

fallingAlarm

1.3.6.1.2.1.16.0.1

–

–

上升报警

1.3.6.1.2.1.16.0.2

–

–

路由通知

BGP 4 MIB

bgp已建立

1.3.6.1.2.1.15.7.1

–

–

bgp向后过渡

1.3.6.1.2.1.15.7.2

–

–

OSPF 陷阱 MIB

ospfVirtIf状态更改

1.3.6.1.2.1.14.16.2.1

–

–

ospfNbr状态更改

1.3.6.1.2.1.14.16.2.2

–

–

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2.3

–

–

ospfIfConfigError

1.3.6.1.2.1.14.16.2.4

–

–

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2.5

–

–

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2.6

–

–

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2.7

–

–

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2.8

–

–

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2.9

–

–

ospfTx重传

1.3.6.1.2.1.14.16.2.10

–

–

ospfVirtIfTx重传

1.3.6.1.2.1.14.16.2.11

–

–

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2.13

–

–

ospfIfStateChange

1.3.6.1.2.1.14.16.2.16

–

–

启动通知

RFC 1907, 简单网络管理协议 (SNMPv2) 版本 2 的管理信息库

冷启动

1.3.6.1.6.3.1.1.5.1

严重

SNMPD_TRAP_ COLD_START

暖启动

1.3.6.1.6.3.1.1.5.2

错误

SNMPD_TRAP_ WARM_START

认证失败

1.3.6.1.6.3.1.1.5.5

注意

SNMPD_TRAP_ GEN_FAILURE

VRRP 通知

RFC 2787, 虚拟路由器冗余协议托管对象的定义

vrrp陷阱新主

1.3.6.1.2.1.68.0.1

警告

VRRPD_ NEWMASTER_陷阱

vrrpTrapAuthFailure

1.3.6.1.2.1.68.0.2

警告

VRRPD_AUTH_ FAILURE_陷阱

表 4:QFX 系列独立交换机和 QFX 系列虚拟机箱支持的企业特定 SNMPv2 陷阱

源 MIB

陷阱名称

SNMP 陷阱 OID

系统日志记录严重性级别

系统日志标记

机箱(报警情况)通知

机箱 MIB (mib-jnx-chassis)

jnx电源故障

1.3.6.1.4.1.2636.4.1.1

警报

CHASSISD_ SNMP_陷阱

 

jnxFanFailure

1.3.6.1.4.1.2636.4.1.2

严重

CHASSISD_ SNMP_陷阱

 

jnx过温

1.3.6.1.4.1.2636.4.1.3

严重

CHASSISD_ SNMP_陷阱

 

jnxFruRemoval

1.3.6.1.4.1.2636.4.1.5

注意

CHASSISD_ SNMP_陷阱

 

jnxFru插入

1.3.6.1.4.1.2636.4.1.6

注意

CHASSISD_ SNMP_陷阱

 

jnxFru断电

1.3.6.1.4.1.2636.4.1.7

注意

CHASSISD_ SNMP_陷阱

 

jnxFruPowerOn

1.3.6.1.4.1.2636.4.1.8

注意

CHASSISD_ SNMP_陷阱

 

jnxFruFailed

1.3.6.1.4.1.2636.4.1.9

警告

CHASSISD_ SNMP_陷阱

 

jnxFru离线

1.3.6.1.4.1.2636.4.1.10

注意

CHASSISD_ SNMP_陷阱

 

jnxFru在线

1.3.6.1.4.1.2636.4.1.11

注意

CHASSISD_ SNMP_陷阱

 

jnxFruCheck

1.3.6.1.4.1.2636.4.1.12

注意

CHASSISD_ SNMP_陷阱

 

jnx 电源正常

1.3.6.1.4.1.2636.4.2.1

严重

CHASSISD_ SNMP_陷阱

 

jnxFanOK

1.3.6.1.4.1.2636.4.2.2

严重

CHASSISD_ SNMP_陷阱

 

jnx温度正常

1.3.6.1.4.1.2636.4.2.3

警报

CHASSISD_ SNMP_陷阱

配置通知

配置管理 MIB (mib-jnx-cfgmgmt)

jnxCmCfgChange

1.3.6.1.4.1.2636.4.5.0.1

–

–

jnxCmRescueChange

1.3.6.1.4.1.2636.4.5.0.2

–

–

远程操作通知

ping MIB (mib-jnx-ping)

jnxPingRttThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.1

–

–

jnxPingRttStdDevThreshold 超出

1.3.6.1.4.1.2636.4.9.0.2

–

–

jnxPingRttJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.3

–

–

jnxPingEgressThreshold 超出

1.3.6.1.4.1.2636.4.9.0.4

–

–

jnxPingEgressStdDevThreshold 超出

1.3.6.1.4.1.2636.4.9.0.5

–

–

jnxPingEgressJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.6

–

–

jnxPingIngressThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.7

–

–

jnxPingIngressStddevThreshold 超出

1.3.6.1.4.1.2636.4.9.0.8

–

–

jnxPingIngressJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.9

–

–

RMON 报警

RMON MIB (mib-jnx-rmon)

jnxRmonAlarmGetFailure

1.3.6.1.4.1.2636.4. 3.0.1

–

–

jnxRmonGetOk

1.3.6.1.4.1.2636.4. 3.0.2

–

–

QFabric 系统支持 SNMP 陷阱

QFabric 系统支持标准 SNMPv2 陷阱和瞻博网络企业专用 SNMPv2 陷阱。

注意:

QFabric 系统不支持 SNMPv1 陷阱。

有关详细信息,请参阅:

  • 标准 SNMPv2 陷阱的表 5

  • 表 6 瞻博网络企业专用 SNMPv2 陷阱

表 5:QFabric 系统支持的标准 SNMPv2 陷阱

定义于

陷阱名称

SNMP 陷阱 OID

系统日志记录严重性级别

系统日志标记

链接通知

RFC 2863, 接口组 MIB

链路向下

1.3.6.1.6.3.1.1.5.3

警告

SNMP_TRAP_ LINK_DOWN

链接

1.3.6.1.6.3.1.1.5.4

信息

SNMP_TRAP_ LINK_UP

启动通知

RFC 1907, 简单网络管理协议 (SNMPv2) 版本 2 的管理信息库

冷启动

1.3.6.1.6.3.1.1.5.1

严重

SNMPD_TRAP_ COLD_START

暖启动

1.3.6.1.6.3.1.1.5.2

错误

SNMPD_TRAP_ WARM_START

认证失败

1.3.6.1.6.3.1.1.5.5

注意

SNMPD_TRAP_ GEN_FAILURE

表 6:QFabric 系统支持的企业特定 SNMPv2 陷阱

源 MIB

陷阱名称

SNMP 陷阱 OID

系统日志记录严重性级别

系统日志标记

交换矩阵机箱 MIB (mib-jnx-fabric-机箱)

交换矩阵机箱(报警情况)通知

jnxFabricPowerSupply故障

1.3.6.1.4.1.2636.4.19.1

警告

–

jnxFabricFanFailure

1.3.6.1.4.1.2636.4.19.2

严重

–

jnxFabricOverTemperature

1.3.6.1.4.1.2636.4.19.3

警报

–

jnxFabric冗余切换

1.3.6.1.4.1.2636.4.19.4

注意

–

jnxFabricFruRemoval

1.3.6.1.4.1.2636.4.19.5

注意

–

jnxFabricFru插入

1.3.6.1.4.1.2636.4.19.6

注意

–

jnxFabricFru关机

1.3.6.1.4.1.2636.4.19.7

注意

–

jnxFabricFruPowerOn

1.3.6.1.4.1.2636.4.19.8

注意

–

jnxFabricFruFailed

1.3.6.1.4.1.2636.4.19.9

警告

–

jnxFabricFru离线

1.3.6.1.4.1.2636.4.19.10

注意

–

jnxFabricFruOnline

1.3.6.1.4.1.2636.4.19.11

注意

–

jnxFabricFruCheck

1.3.6.1.4.1.2636.4.19.12

警告

–

jnxFabricFEBSwitchover

1.3.6.1.4.1.2636.4.19.13

警告

–

jnxFabricHardDiskFailed

1.3.6.1.4.1.2636.4.19.14

警告

–

jnxFabricHardDiskMissing

1.3.6.1.4.1.2636.4.19.15

警告

–

jnxFabricBootFromBackup

1.3.6.1.4.1.2636.4.19.16

警告

–

交换矩阵机箱(告警清除条件)通知

jnxFabricPowerSupplyOK

1.3.6.1.4.1.2636.4.20.1

严重

–

jnxFabricFanOK

1.3.6.1.4.1.2636.4.20.2

严重

–

jnxFabricTemperatureOK

1.3.6.1.4.1.2636.4.20.3

警报

–

jnxFabricFruOK

1.3.6.1.4.1.2636.4.20.4

–

–

QFabric MIB (mib-jnx-qf-smi)

QFabric MIB 通知

jnxQFabricDownloadIssued

1.3.6.1.4.1.2636.3.42.1.0.1

–

–

jnxQFabricDownloadFailed

1.3.6.1.4.1.2636.3.42.1.0.2

–

–

jnxQFabricDownloadSucceeded

1.3.6.1.4.1.2636.3.42.1.0.3

–

–

jnxQFabricUpgrade已发布

1.3.6.1.4.1.2636.3.42.1.0.4

–

–

jnxQFabricUpgradeFailed

1.3.6.1.4.1.2636.3.42.1.0.5

–

–

jnxQFabricUpgradeSucceeded

1.3.6.1.4.1.2636.3.42.1.0.6

–

–

配置通知

配置管理 MIB (mib-jnx-cfgmgmt)

jnxCmCfgChange

1.3.6.1.4.1.2636.4.5.0.1

–

–

jnxCmRescueChange

1.3.6.1.4.1.2636.4.5.0.2

–

–

远程操作通知

ping MIB (mib-jnx-ping)

jnxPingRttThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.1

–

–

jnxPingRttStdDevThreshold 超出

1.3.6.1.4.1.2636.4.9.0.2

–

–

jnxPingRttJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.3

–

–

jnxPingEgressThreshold 超出

1.3.6.1.4.1.2636.4.9.0.4

–

–

jnxPingEgressStdDevThreshold 超出

1.3.6.1.4.1.2636.4.9.0.5

–

–

jnxPingEgressJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.6

–

–

jnxPingIngressThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.7

–

–

jnxPingIngressStddevThreshold 超出

1.3.6.1.4.1.2636.4.9.0.8

–

–

jnxPingIngressJitterThreshold 已超出

1.3.6.1.4.1.2636.4.9.0.9

–

–

Junos OS 支持的标准 SNMP 陷阱

本主题提供运行 Junos OS 的设备支持的标准 SNMPv1 和 SNMPv2 陷阱列表。有关陷阱的详细信息,请参阅 SNMP MIB 资源管理器。

在平滑路由引擎切换 (GRES) 之后,新的主路由引擎将发送单个 warmStart 通知。当设备启动时,主路由引擎会发送 coldStart 通知。主路由引擎还会发送 warmStart SNMP 守护程序后续重启的通知。GRES 之后,新的主路由引擎会发送单个 warmStart 通知,而备用路由引擎不会发送任何通知。

标准 SNMP 版本 1 陷阱

表 7 概述了 SNMPv1 的标准陷阱。陷阱首先按陷阱类别组织,然后按陷阱名称组织,并包括其企业 ID、通用陷阱编号和特定陷阱编号。对于具有这些陷阱及其相应的系统日志标记,系统日志记录严重性级别将列出。没有相应系统日志记录严重性级别的陷阱在表中用破折号 (–) 标记。

有关系统日志消息的更多信息,请参阅 系统日志资源管理器。

表 7:标准支持的 SNMP 版本 1 陷阱

定义于

陷阱名称

企业 ID

通用陷阱编号

特定陷阱编号

系统日志记录严重性级别

系统日志标记

支持

启动通知

RFC 1215, 用于定义用于 SNMP 的陷阱的约定

authenticationFailure

1.3.6.1.4.1.2636

4

0

注意

SNMPD_ TRAP_ GEN_FAILURE

所有运行 Junos OS 的设备。

coldStart

1.3.6.1.4.1.2636

0

0

严重

SNMPD_TRAP_ COLD_START

所有运行 Junos OS 的设备。

warmStart

1.3.6.1.4.1.2636

1

0

错误

SNMPD_TRAP_ WARM_START

所有运行 Junos OS 的设备。

链接通知

RFC 1215, 用于定义用于 SNMP 的陷阱的约定

linkDown

1.3.6.1.4.1.2636

2

0

警告

SNMP_ TRAP_ LINK_DOWN

所有运行 Junos OS 的设备。

linkUp

1.3.6.1.4.1.2636

3

0

信息

SNMP_TRAP_ LINK_UP

所有运行 Junos OS 的设备。

远程操作通知

RFC 2925, 用于远程 Ping、Traceroute 和查找操作的托管对象的定义

pingProbeFailed

1.3.6.1.2.1.80.0

6

1

信息

SNMP_TRAP _PING_ PROBE_失败

所有运行 Junos OS 的设备。

pingTestFailed

1.3.6.1.2.1.80.0

6

2

信息

SNMP_TRAP_ PING_TEST _FAILED

所有运行 Junos OS 的设备。

pingTestCompleted

1.3.6.1.2.1.80.0

6

3

信息

SNMP_TRAP_ PING_TEST_已完成

所有运行 Junos OS 的设备。

RMON 报警

RFC 2819a,RMON MIB

fallingAlarm

1.3.6.1.2.1.16

6

2

–

–

所有运行 Junos OS 的设备。

risingAlarm

1.3.6.1.2.1.16

6

1

–

–

所有运行 Junos OS 的设备。

路由通知

BGP 4 MIB

bgpEstablished

1.3.6.1.2.1.15.7

6

1

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

bgpBackwardTransition

1.3.6.1.2.1.15.7

6

2

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

OSPF 陷阱 MIB

ospfVirtIfStateChange

1.3.6.1.2.1.14.16.2

6

1

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfNbrStateChange

1.3.6.1.2.1.14.16.2

6

2

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2

6

3

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfIfConfigError

1.3.6.1.2.1.14.16.2

6

4

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2

6

5

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2

6

6

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2

6

7

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

8

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2

6

9

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfTxRetransmit

1.3.6.1.2.1.14.16.2

6

10

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfVirtIfTxRetransmit

1.3.6.1.2.1.14.16.2

6

11

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2

6

13

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

ospfIfStateChange

1.3.6.1.2.1.14.16.2

6

16

–

–

MX 和 EX 系列设备以及 SRX 系列防火墙。

VRRP 通知

RFC 2787, 虚拟路由器冗余协议托管对象的定义

vrrpTrapNewMaster

1.3.6.1.2.1.68

6

1

警告

VRRPD_NEW MASTER_TRAP

所有运行 Junos OS 的设备。

vrrpTrapAuthFailure

1.3.6.1.2.1.68

6

2

警告

VRRPD_AUTH_ FAILURE_TRAP

所有运行 Junos OS 的设备。

RFC 6527, 虚拟路由器冗余协议第 3 版 (VRRPv3) 托管对象的定义

vrrpv3NewMaster

1.3.6.1.2.1.207

6

1

警告

VRRPD_NEW_MASTER

MX 系列设备。

vrrpv3ProtoError

1.3.6.1.2.1.207

6

2

警告

VRRPD_V3_PROTO_ERROR

MX 系列设备。

标准 SNMP 版本 2 陷阱

表 8 概述了 Junos OS 支持的标准 SNMPv2 陷阱。陷阱首先按陷阱类别组织,然后按陷阱名称组织,并包括其 snmpTrapOID。对于具有这些陷阱及其相应的系统日志标记,系统日志记录严重性级别将列出。没有相应系统日志记录严重性级别的陷阱在表中用破 折号 (–) 标记。

表 8:标准支持的 SNMP 版本 2 陷阱

定义于

陷阱名称

snmpTrapOID

系统日志记录严重性级别

系统日志标记

支持

启动通知

RFC 1907, 简单网络管理协议 (SNMPv2) 版本 2 的管理信息库

coldStart

1.3.6.1.6.3.1.1.5.1

严重

SNMPD_TRAP_ COLD_START

所有运行 Junos OS 的设备。

warmStart

1.3.6.1.6.3.1.1.5.2

错误

SNMPD_TRAP_ WARM_START

所有运行 Junos OS 的设备。

authenticationFailure

1.3.6.1.6.3.1.1.5.5

注意

SNMPD_TRAP_ GEN_FAILURE

所有运行 Junos OS 的设备。

链接通知

RFC 2863, 接口组 MIB

linkDown

1.3.6.1.6.3.1.1.5.3

警告

SNMP_TRAP_ LINK_DOWN

所有运行 Junos OS 的设备。

linkUp

1.3.6.1.6.3.1.1.5.4

信息

SNMP_TRAP_ LINK_UP

所有运行 Junos OS 的设备。

远程操作通知

RFC 2925, 用于远程 Ping、Traceroute 和查找操作的托管对象的定义

pingProbeFailed

1.3.6.1.2.1.80.0.1

信息

SNMP_TRAP_ PING_PROBE_失败

所有运行 Junos OS 的设备。

pingTestFailed

1.3.6.1.2.1.80.0.2

信息

SNMP_TRAP_PING_ TEST_FAILED

所有运行 Junos OS 的设备。

pingTestCompleted

1.3.6.1.2.1.80.0.3

信息

SNMP_TRAP_PING_ TEST_COMPLETED

所有运行 Junos OS 的设备。

RMON 报警

RFC 2819a,RMON MIB

fallingAlarm

1.3.6.1.2.1.16.0.1

–

–

所有运行 Junos OS 的设备。

risingAlarm

1.3.6.1.2.1.16.0.2

–

–

所有运行 Junos OS 的设备。

路由通知

BGP 4 MIB

bgpEstablished

1.3.6.1.2.1.15.7.1

–

–

所有运行 Junos OS 的设备。

bgpBackwardTransition

1.3.6.1.2.1.15.7.2

–

–

所有运行 Junos OS 的设备。

OSPF 陷阱 MIB

ospfVirtIfStateChange

1.3.6.1.2.1.14.16.2.1

–

–

所有运行 Junos OS 的设备。

ospfNbrStateChange

1.3.6.1.2.1.14.16.2.2

–

–

所有运行 Junos OS 的设备。

ospfVirtNbrStateChange

1.3.6.1.2.1.14.16.2.3

–

–

所有运行 Junos OS 的设备。

ospfIfConfigError

1.3.6.1.2.1.14.16.2.4

–

–

所有运行 Junos OS 的设备。

ospfVirtIfConfigError

1.3.6.1.2.1.14.16.2.5

–

–

所有运行 Junos OS 的设备。

ospfIfAuthFailure

1.3.6.1.2.1.14.16.2.6

–

–

所有运行 Junos OS 的设备。

ospfVirtIfAuthFailure

1.3.6.1.2.1.14.16.2.7

–

–

所有运行 Junos OS 的设备。

ospfIfRxBadPacket

1.3.6.1.2.1.14.16.2.8

–

–

所有运行 Junos OS 的设备。

ospfVirtIfRxBadPacket

1.3.6.1.2.1.14.16.2.9

–

–

所有运行 Junos OS 的设备。

ospfTxRetransmit

1.3.6.1.2.1.14.16.2.10

–

–

所有运行 Junos OS 的设备。

ospfVirtIfTxRetransmit

1.3.6.1.2.1.14.16.2.11

–

–

所有运行 Junos OS 的设备。

ospfMaxAgeLsa

1.3.6.1.2.1.14.16.2.13

–

–

所有运行 Junos OS 的设备。

ospfIfStateChange

1.3.6.1.2.1.14.16.2.16

–

–

所有运行 Junos OS 的设备。

MPLS 通知

RFC 3812,MPLS (MPLS) 流量工程 (流量工程) 管理信息库

mplsTunnelUp

mplsTunnelDown

mplsTunnelRerouted

mplsTunnelReoptimized

实体状态 MIB 通知

RFC 4268, 实体状态 MIB

entStateOperEnabled

1.3.6.1.2.1.131.0.1

注意

CHASSISD_SNMP_TRAP3

MX240、MX480 和 MX960

entStateOperDisabled

1.3.6.1.2.1.131.0.2

注意

CHASSISD_SNMP_TRAP3

MX240、MX480 和 MX960

L3VPN 通知

RFC  4382,MPLS/BGP 3 层虚拟专用网络 (VPN)

mplsL3VpnVrfUp

mplsL3VpnVrfDown

mplsL3VpnVrf RouteMidThresh Exceeded

mplsL3VpnVrf NumVrfRouteMax ThreshExceeded

mplsL3VpnNum VrfRouteMax ThreshCleared

VRRP 通知

RFC 2787, 虚拟路由器冗余协议托管对象的定义

vrrpTrapNewMaster

1.3.6.1.2.1.68.0.1

警告

VRRPD_ NEWMASTER_陷阱

所有运行 Junos OS 的设备。

vrrpTrapAuthFailure

1.3.6.1.2.1.68.0.2

警告

VRRPD_AUTH_ FAILURE_陷阱

所有运行 Junos OS 的设备。

RFC 6527, 虚拟路由器冗余协议第 3 版 (VRRPv3) 托管对象的定义

vrrpv3NewMaster

1.3.6.1.2.1.207.0.1

警告

VRRPD_NEW_MASTER

MX 系列设备。

vrrpv3ProtoError

1.3.6.1.2.1.207.0.2

警告

VRRPD_V3_PROTO_ERROR

MX 系列设备。

用于系统日志陷阱的定制 SNMP MIB

SNMP 系统日志陷阱是从启用 SNMP 的远程设备发送到中央收集器的警报消息,用于通知您组件故障或关键资源超出可配置限制的情况。此信息被捕获在管理信息库 (MIB) 中。瞻博网络企业专用系统日志 MIB 支持在出现重要的系统日志消息时通知基于 SNMP 陷阱的应用。定义 MIB 是为了将系统日志条目映射到通用 jnxSyslogTrap OID。

jnxSyslogTrap OID 是基于系统日志中生成的日志的陷阱。事件进程 (eventd) 监控系统日志,并根据系统日志事件的事件策略 raise-trap 配置语句,将所有系统日志事件发送到一个通用系统日志定义的陷阱 MIB,即 jnxSyslogTrap。

对于想要处理系统日志陷阱 OID 值来发现特定事件的客户来说,使用一个通用 MIB OID 会很不方便,因为无法区分具有相同 OID 的告警。但从 Junos OS 18.3R1 版开始,您可以将自定义 OID 映射到特定日志,并将其动态加载到设备上。

此功能的好处是,由于有一种方法可以将特定 OID 分配给不同类型的系统日志事件,您现在可以有效地监控每种不同类型的系统日志事件。

自定义 SNMP MIB 概述

要为系统日志陷阱创建自定义 SNMP MIB,您必须完成以下任务:

  • 编写自定义 MIB。

  • 将 MIB 文件转换为 YANG 格式并将 YANG 文件复制到设备。

  • 将 YANG 文件加载到设备上。

以下部分概述了这些步骤。

写入 MIB 文件

在将特定日志与自定义 OID 映射之前,必须先编写自定义 MIB。为避免冲突,您必须仅在 表 9 所示的保留根下定义 MIB 对象和陷阱。

表 9:自定义 MIB 模块的 MIB 根

Root

描述

OID

.iso.org.dod.internet.private.enterprises.juniperMIB.jnxMibs.jnxCustomMibRoot

自定义 MIB 模块

.1.3.6.1.4.1.2636.3.86

.iso.org.dod.internet.private.enterprises.juniperMIB.jnxTraps.jnxCustomSyslogNotifications

自定义陷阱通知

.1.3.6.1.4.1.2636.4.30

转换为 YANG 文件

将 MIB 定义加载到设备上之前,必须将 MIB 文件转换为 YANG 格式。将 MIB 文件转换为 YANG 的推荐方法是使用 smidump v0.5.0 工具。smidump 工具是一个开源应用程序,可以安装在您的笔记本电脑上(参见 https://www.ibr.cs.tu-bs.de/projects/libsmi/smidump.html)。

文件采用 YANG 格式后,您必须将其复制到设备上。然后,使用 CLI 命令,将 加载到 SNMP 进程 (snmpd) 中。然后生成一个相应的 JSON 文件,snmpd 解析该文件并从中构建 OID 层次结构的数据库。如果发现一些未知标记,snmpd 将返回相应的错误消息。

用于管理 YANG 文件的 CLI 命令

要将 YANG 模块加载到 snmpd 中,请将该 snmp 选项与以下 request system yang add 命令一起使用:

包括 yang-filename 绝对路径。

注意:

要运行该 request system yang add 命令,您必须具有超级用户访问权限。

还有另外两个命令用于管理设备上的 YANG 文件: show system yang package 和 request system yang delete。

为系统日志陷阱定义自定义 MIB

在此过程中,我们将使用以下示例文件:

  • 要转换的 MIB 文件

  • 输出

注意:

尽管可以通过参考本文档中提供的示例 YANG 手动编写 YANG,但我们建议您使用 smidump 工具 v0.5.0 将 MIB 转换为 YANG 格式。

要为系统日志陷阱定义自定义 MIB,请执行以下操作:

  1. 将 MIB 加载到网络管理系统 (NMS) 上,然后检查是否存在任何错误。
  2. 使用以下命令调用 smidump 工具,其中 dependency-mib、 和 input-custom-mib-file是 YANG-MODULE-NAME 特定文件名的变量:

    例如:

    作为输出,您将获得转换后的 YANG 文件 JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB.yang。

    请注意,输入自定义MIB文件 mib-jnx-example-custom-syslog.txt 依赖于 SNMPv2-SMI、JUNIPER-SMI 和 IF-MIB。但是,由于 SNMPv2-SMI 和 IF-MIB 是标准 MIB,因此它们的定义已存在于 smidump 中。因此,唯一需要的依赖MIB文件是 mib-jnx-smi.txt,其中包含模块 JUNIPER-SMI 定义。

  3. 将文件 JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB.yang 复制到设备上的任意路径,然后通过以下路径将所有依赖的 YANG 文件复制到设备: /opt/lib/python2.7/site-packages/pyang/modules。
    注意:

    您必须将所有从属 MIB 转换为 YANG 文件,然后将其复制到设备。

    以下是一些已转换为 YANG 模块并存在于上述路径中的标准 MIB: IANAifType-MIB.yang、 ietf-yang-types.yang、 ietf-inet-types.yang、 IF-MIB.yang、 JUNIPER-SMI.yang、 SNMPv2-TC.yang。

  4. 使用 CLI,使用以下命令将 YANG 模块加载到 snmpd 中:

    例如:

    YANG 模块被转换为 JSON 格式并转到 snmpd 进行解析和创建内部数据库。

  5. 要根据系统日志和新添加的陷阱定义验证陷阱是否正常工作,请欺骗(模拟)陷阱。您可以使用 CLI 或事件策略执行此操作。以下是使用 CLI 欺骗陷阱的示例。

mib-jnx-example-custom-syslog.txt

JUNIPER-EXAMPLE-CUSTOM-SYSLOG-MIB.YANG

使用自定义 SNMP 陷阱的限制

请小心以这样一种方式编写事件脚本,以免它们为频繁发生的系统日志触发陷阱。此做法可避免在设备上引入更多负载。

如果添加访问类型为 readonly 或 readwrite的对象,则该对象将无法在 SNMP 轮询操作(如 snmpget 或 snmpwalk)中进行轮询;它将被视为访问类型notifyonly。这是因为此功能用于向设备添加动态 TRAP OID 定义,以便客户可以编写脚本为每个系统日志发送自定义陷阱。接入类型readonly,notifyonly用于 readwrite SNMP 轮询,而用于陷阱。

对于自定义 MIB,不支持自定义表的定义。如果要发送具有表对象作为 varbind 的陷阱,请使用 Junos MIB 中已定义的表,而不是在自定义 MIB 中定义自定义表。

YANG 文件需要分别加载到所有机箱节点和路由引擎上。该 request system yang add 命令不会自动将其复制到备份路由引擎。

自定义系统日志陷阱示例

此示例自定义系统日志陷阱说明了一个用例,在该用例中,运维人员希望在发生以下任一情况时接收陷阱:

  • 用户在 CLI 中进入配置模式(事件定义为 ui_dbase_login_event)

  • 用户执行提交(事件定义为 ui_commit

在支持自定义系统日志陷阱功能之前,唯一的方法是对这两个事件使用具有固定 OID 的 jnxSyslogTrap。使用自定义系统日志陷阱功能,您现在可以生成具有自定义定义 OID 的陷阱。

要定义自定义系统日志陷阱,请执行以下操作:

  1. 使用提供的示例文件并将其转换为 JUNIPER-EXAMPLE-CUSTOM-SYSLOIG-MIB.yang 。
  2. 将 YANG 文件复制到设备上。
  3. 加载 SNMP YANG 文件。
  4. 将 slax 脚本复制到 /var/db/scripts/event 以欺骗陷阱。

    对于ui_dbase_login_event,您将配置用户名为 varbind 的 enteredConfigMode 陷阱。

    对于ui_commit,您将配置 configCommitted 陷阱,该陷阱将 username 命令注释作为三个 varbind。

  5. 配置陷阱:
  6. 启用 snmpd traceoptions 和陷阱目标以验证发送的陷阱。
  7. 验证陷阱是否正常工作。

示例 MIB 文件

示例 YANG 转换后的文件

slax 脚本 cutom_trap.slax(在 /var/db/scripts/event 中)

特定于平台的 SNMP 陷阱行为

使用 功能资源管理器 确认平台和版本对特定功能的支持。

使用下表查看平台的特定于平台的行为。

平台 差异

EX 系列

  • 支持 SNMP 陷阱的 EX 系列交换机仅从监控 CPU 温度的传感器为灵活 PIC 集中器 (FPC) 生成过温 SNMP 陷阱,而相同的交换机会从所有传感器为控制板 (控制板) 生成过温 SNMP 陷阱。

变更历史表

是否支持某项功能取决于您使用的平台和版本。使用 功能资源管理器 确定您的平台是否支持某个功能。

发布
描述
20.1R1
从 Junos OS 20.1 版开始,在平滑路由引擎切换 (GRES) 之后,新的主路由引擎将发送单个 warmStart 通知。