配置 TWAMP

双向有源测量协议 (TWAMP) 定义了用于测量网络中两台设备之间 IP 性能的标准。有关 TWAMP 的详细信息,请参阅 RFC 5357, 双向有源测量协议 (TWAMP)。有关 TWAMP 的更多背景信息,请参阅 了解双向有源测量协议。

了解 TWAMP 配置

双向主动测量协议 (TWAMP) 支持和配置因硬件平台、物理接口或虚拟物理(服务)接口而异。对 RPM 的支持并不总是在 Junos OS 的特定平台和线卡组合上支持 TWAMP 的指标。RPM 和 TWAMP 中使用的时间戳会添加到不同位置,具体取决于硬件配置。例如,不同的硬件组件执行时间戳记,可以在查找 (LU) 芯片、路由引擎 (Junos OS 演化版)、主机数据包转发引擎或线卡(例如多服务物理接口卡 (MS-PIC)、多服务模块化接口卡 (MS-MIC)、多服务模块化 PIC 集中器 (MS-MPC) 或多服务密集端口集中器 (MS-DPC) 中执行时间戳记。

使用 功能浏览器:双向主动测量协议 来确认平台并发布对特定功能的支持。

请参阅了解 Junos OS Evolved 的 双向主动测量协议 ,有关您平台的差异和说明。

TWAMP 灯支持

如 RFC 5357 附录 I 中所定义的 TWAMP Light 是 TWAMP 的无状态版本,其中测试参数是预定义的,而不是协商的。服务器在测试端口上收到的所有测试数据包都会被反射回来,并立即被遗忘。

Junos OS 21.3R1 版中引入了对 TWAMP Light 测试会话的 IPv6 目标地址的支持。对于 Junos OS IPv6 TWAMP Light 客户端,您必须在层次结构级别配置 [edit services rpm twamp client control-connection control-client-name test-session test-session-name] 和 target-address 语destination-port句。从 Junos OS 21.4R1 版和 Junos OS 演化版 22.3R1 版开始,对于支持 TWAMP Light 的设备,IPv6 TWAMP Light 测试会话的链路本地目标地址支持。

支持简单的双向有源测量协议 (STAMP)

STAMP 在 RFC 8762 中定义, 简单双向有源测量协议 (STAMP),对 RFC 5357 附录 I 中定义的 TWAMP Light作模式进行了标准化和扩展,该模式在 RFC 5357 的附录 I 中定义, 双向有源测量协议 (TWAMP)。符合 STAMP 标准的反射器可确保有效负载大小对称(根据 RFC 6038),并在无状态或有状态模式下运行,具体取决于反射有效负载中的序列号是从客户端帧复制还是独立生成。有状态反射器可以检测发生丢包的方向。在以前的版本中,我们支持对称有效负载和无状态反射。我们现在支持有状态反射、完全符合 STAMP 标准以及客户端的单向丢弃值。我们不仅支持 STAMP 客户端的单向丢弃值,还支持 TWAMP 托管模式客户端的单向丢弃值。对于 Junos OS 演化版,STAMP 配置在 [edit services monitoring twamp server light] 层次结构级别。有状态反射通过 stateful-sequence 语句配置。对于服务器,新的默认值 offload-type 是 now pfe-timestamp 而不是 inline-timestamp。

使用 功能浏览器:简单双向主动测量协议 (STAMP) 确认平台和版本支持。

TWAMP 托管支持

对于 Junos OS,TWAMP 是在层次结构级别配置 [edit services rpm twamp] 的。对于 Junos OS 演化版,TWAMP 在层次结构级别进行 [edit services monitoring twamp] 配置。

使用 双向主动测量协议 确认平台并发布对特定功能的支持。

配置 TWAMP 服务器

除物理接口外,Junos OS 的 TWAMP 服务器配置需要在 ] 层次结构级别进行 [edit services rpm twamp以下最低配置:

从 Junos OS 21.3R1 版开始,不再需要配置该 authentication-mode 语句。默认模式现在 none是 ,这意味着与服务器的通信不会经过身份验证。

  • 要指定可连接到此服务器的允许控制客户端主机列表,请在层次结构级别包含[edit services rpm twamp server]该client-list语句。您包含的每个值都必须是表示允许的主机网络的无类域间路由 (CIDR) 地址(IP 地址加掩码)。您可以包含多个客户端列表,每个客户端列表最多可以包含 64 个条目。您必须至少配置一个客户端地址才能启用 TWAMP。

  • ACX 系列路由器不支持身份验证和加密模式。层次结构级别的 statement 值authentication-mode必须设置为 none。[edit services rpm twamp server]

  • TWAMP 控制 连接流量始终到达侦听端口设置为 862 的 ACX 路由器。由于流量探针的此端口号可修改,因此 ACX 路由器无法正确识别和处理使用不同端口号到达的探针。因此,在这种情况下,TWAMP 流量和主机绑定的数据包将被丢弃。

配置 TWAMP 提供有关支持服务器灯光控制的信息。

对于 Junos OS,您可以为服务器配置灯光控制(默认为托管控制)。用于灯光控制的 Junos OS TWAMP 服务器配置需要在层次结构级别进行 [edit services rpm twamp] 以下最低配置:

对于 Junos OS,有关源地址的限制列表,请参阅源地址 (TWAMP)。

对于 Junos OS 演化版,您可以为服务器配置托管控制或轻量控制。用于托管或轻型控制的 TWAMP 服务器配置要求在层次结构级别上 [edit services monitoring twamp] 进行以下最低配置(假设您使用 TWAMP 的默认端口 (862):

对于 Junos OS 演化版,不能将以下地址用于用于探测的客户端列表源 IP 地址:

  • 0.0.0.0

  • 127.0.0.0/8(环路)

  • 224.0.0.0/4(组播)

  • 255.255.255.255(广播)

您可以配置多个客户端,并且只要更改与 TWAMP 客户端协调即可更改 TWAMP 侦听端口。

对于 Junos OS 中基于微内核的时间戳,无需配置 si- 接口。在这种情况下,TWAMP 连接和会话将基于目标地址和路由建立。

对于 Junos OS 中的内联时间戳,您需要配置 si- 或 sp- 服务接口,并且 TWAMP 服务器配置需要在层次结构级别使用 [edit interfaces service-interface-name] 以下语句:

注意:

无法在服务接口的单元 0 上配置 TWAMP 服务器。如果尝试,您将收到配置错误。

(仅限 Junos OS)要在内联服务 (si-) 接口上配置 TWAMP 服务器,请通过在层次结构级别包含[edit chassis fpc slot-number pic number inline-services]该语句,为bandwidth (1g | 10g)使用内联服务的隧道流量配置每个数据包转发引擎上为使用内联服务的流量预留的带宽量。通过在层次结构级别包含twamp-server[edit interfaces sp-fpc/pic/port unit logical-unit-number family inet]语句,指定提供 TWAMP 服务的服务 PIC (sp-) 逻辑接口。

物理接口 TWAMP 服务器配置不需要该 twamp-server 语句。

许多其他 TWAMP 服务器参数可选。有关详细信息,请参阅 TWAMP server 配置语句。

配置 TWAMP 客户端

对于 Junos OS,要配置 TWAMP 客户端服务,请在层次结构级别包括 client [edit services rpm twamp]语句和相关参数。对于 Junos OS 演化版,请在 ] 层次结构级别包含 client [edit services monitoring twamp语句和相关选项。

TWAMP 客户端配置有许多选项可用。有关详细信息,请参阅配置语句主题和示例。

对于 Junos OS 中基于微内核的时间戳,无需配置 si- 接口。在这种情况下,TWAMP 连接和会话将基于目标地址和路由建立。

对于 Junos OS 中的内联时间戳记,接口 si- 是作为 TWAMP 服务器进行响应的虚拟物理接口。但是,您也可以将服务接口配置为充当执行 TWAMP 控制器角色的 TWAMP 客户端。

(仅限 Junos OS)要将服务接口配置为 TWAMP 客户端,请将服务参数和服务接口配置为 TWAMP 客户端。

要配置 TWAMP 客户端服务接口,请在层次结构级别包含[edit interfaces si-interface-name]该rpm twamp-client语句:

注意:

无法在服务接口的单元 0 上配置 TWAMP 客户端。如果尝试,您将收到配置错误。

变更历史表

是否支持某项功能取决于您使用的平台和版本。使用 功能资源管理器 确定您的平台是否支持某个功能。

发布
描述
25.4R1-EVO
我们在内联时间戳功能中添加了对 Flex Algo 和 SR-MPLS 的支持。
25.4R1
对于支持该功能的 MX 线卡,您可以使用该 offload-type inline-timestamp 选项将时间戳记卸载到数据包转发引擎硬件。此内联时间戳记功能还支持 Flex Algo 和 SR-MPLS。在服务器或客户端上配置该 offload-type 语句。
23.4R1-EVO
我们支持 RFC 8762 ,简单双向有源测量协议 (STAMP)。RFC 8762 对 TWAMP Light作模式进行了标准化和扩展,该模式在 RFC 5357 的附录 I 中定义,即双 向主动测量协议 (TWAMP)。符合 STAMP 标准的反射器可确保有效负载大小对称(根据 RFC 6038),并在无状态或有状态模式下运行,具体取决于反射有效负载中的序列号是从客户端帧复制还是独立生成。有状态反射器可以检测发生丢包的方向。在以前的版本中,我们支持对称有效负载和无状态反射。在此版本中,我们支持有状态反射、完全符合 STAMP 标准以及客户端的单向丢弃值。我们不仅支持 STAMP 客户端的单向丢弃值,还支持 TWAMP 托管模式客户端的单向丢弃值。对于服务器,语句的 offload-type 默认值现在是 pfe-timestamp inline-timestamp而不是 。
22.4R1-EVO
我们支持客户端列表、控制连接和测试会话的 IPv6 源地址和目标地址(链路本地地址除外)。
22.4R1-EVO
您可以为 TWAMP 配置 SNMP 陷阱。
22.4R1-EVO
我们支持内联时间戳,其中时间戳记在发生器或反射器的硬件中完成。
22.3R1-EVO
对于 TWAMP Light 测试会话,您可以为目标地址指定 IPv6 链路本地地址。
21.4R1-EVO
客户端列表、控制连接和测试会话支持 IPv6 源地址和目标地址(链路本地地址除外)。
21.4R1
对于 TWAMP Light 测试会话,您可以为目标地址指定 IPv6 链路本地地址,并且可以为与配置了 IPv6 链路本地地址的目标地址对应的源地址配置 IPv6 地址。
21.3R1
支持 TWAMP Light 测试会话的 IPv6 目标地址。
21.3R1
不再需要为 TWAMP 服务器配置 authentication-mode 该语句。默认模式为 none。
21.1R1
我们支持 RFC 5357 附录 I 中定义的双向主动测量协议 (TWAMP) Light 客户端和服务器,用于 IPv4 目标地址。TWAMP Light 是 TWAMP 的无状态版本,其中测试参数是预定义的,而不是协商的。服务器在测试端口上收到的所有测试数据包都会被反射回来,并立即被遗忘。