Padrões IPv6 suportados
O Junos OS oferece suporte substancial aos seguintes RFCs e rascunhos da Internet, que definem padrões para o IP versão 6 (IPv6):
-
RFC 1981, descoberta de caminho de MTU para IP versão 6
-
RFC 2080, RIPng para IPv6
-
RFC 2081, declaração de aplicabilidade do protocolo RIPng
-
RFC 2373, arquitetura de endereçamento IP versão 6
-
RFC 2375, atribuições de endereços multicast
-
RFC 2461, descoberta de vizinhos para IP versão 6 (IPv6)
-
RFC 2462, configuração automática de endereço sem estado IPv6
-
RFC 2463, Protocolo de Mensagem de Controle de Internet (ICMPv6) para a Especificação de Protocolo de Internet Versão 6 (IPv6)
-
RFC 2464, Transmissão de pacotes IPv6 por redes Ethernet
-
RFC 2465, Base de Informações de Gerenciamento para IP Versão 6: Convenções Textuais e Grupo Geral
Não há suporte para estatísticas de IP versão 6 (IPv6) e Internet Control Message Protocol versão 6 (ICMPv6).
-
RFC 2472, IP versão 6 sobre PPP
-
RFC 2474, definição do campo de serviços diferenciados (campo DS) nos cabeçalhos IPv4 e IPv6
-
RFC 2491, IPv6 sobre redes NBMA (Non-Broadcast Multiple Access)
-
RFC 2492, IPv6 sobre redes ATM
-
RFC 2526, endereços anycast de sub-rede IPv6 reservados
-
RFC 2545, uso de extensões multiprotocolo BGP-4 para roteamento entre domínios IPv6
-
RFC 2578, Estrutura de Informações de Gerenciamento Versão 2 (SMIv2)
-
RFC 2675, Jumbogramas IPv6
-
RFC 2711, opção de alerta de roteador IPv6
-
RFC 2767, hosts de pilha dupla usando a técnica de "colisão-na-pilha" (BIS)
-
RFC 2784, encapsulamento de roteamento genérico
-
RFC 2878, protocolo de controle de ponte PPP (BCP)
-
RFC 3056, conexão de domínios IPv6 por meio de nuvens IPv4.
-
RFC 3306, endereços multicast IPv6 baseados em prefixo unicast
-
RFC 3307, Diretrizes de alocação para endereços IPv6 multicast
-
RFC 3513, arquitetura de endereçamento do protocolo de Internet versão 6 (IPv6)
-
RFC 3515, o método de referência do protocolo de iniciação de sessão (SIP)
-
RFC 3590, seleção de endereço de origem para o ouvinte multicast D (suportado apenas para o modo de inclusão SSM)
-
RFC 3768, protocolo de redundância de roteador virtual (VRRP)
-
RFC 3810, Multicast Listener Discovery versão 2 (MLDv2) para IPv6
-
RFC 3879, descontinuando endereços locais do site
-
RFC 3971, descoberta segura de vizinhos para IPv6 (sem suporte para caminhos de certificação, ancorado em partes confiáveis)
-
RFC 3972, endereços gerados criptograficamente
-
RFC 4007, arquitetura de endereço com escopo IPv6
-
RFC 4087, MIB de túnel IP
-
RFC 4193, endereços unicast IPv6 locais exclusivos
-
RFC 4213, mecanismos básicos de transição para hosts e roteadores IPv6
O RFC 4213 substitui o RFC 2893, Mecanismos de transição para hosts e roteadores IPv6.
Observação:O suporte de tunelamento configurado de IPv6 sobre IPv4 ou suporte de camada IP dupla pode variar de acordo com o switch. A maioria dos switches suporta apenas a camada de IP dupla, enquanto alguns podem suportar ambas.
-
RFC 4291, arquitetura de endereçamento IP versão 6
-
RFC 4292, tabela de encaminhamento de IP MIB
-
RFC 4293, Base de Informações de Gerenciamento para o Protocolo de Internet (IP)
-
RFC 4294, requisitos de nó IPv6 (suporte parcial)
-
RFC 4443, Protocolo de Mensagem de Controle de Internet (ICMPv6) para a Especificação de Protocolo de Internet Versão 6 (IPv6)
-
RFC 4552, autenticação/confidencialidade para OSPFv3
-
RFC 4604, usando o protocolo de gerenciamento de grupos da Internet versão 3 (IGMPv3)
-
RFC 4659, extensão de rede privada virtual (VPN) IP BGP-MPLS para VPN IPv6
-
RFC 4798, Conectando ilhas IPv6 por IPv4 MPLS usando roteadores de borda de provedor IPv6 (6PE)
A opção 4b (redistribuição eBGP de rotas IPv6 rotuladas do AS para o AS vizinho) não é suportada.
-
RFC 4861 Descoberta de vizinhos para IP versão 6 (IPv6)
-
RFC 4862, configuração automática de endereço sem estado IPv6
-
RFC 4884, ICMP estendido para suportar mensagens de várias partes
-
RFC 4890, recomendações para filtrar mensagens ICMPv6 em firewalls
-
RFC 4942, considerações de segurança de transição/coexistência de IPv6
-
RFC 5072, IP versão 6 sobre PPP
-
RFC 5095, descontinuação de cabeçalhos de roteamento Tipo 0 no IPv6
-
RFC 5308, roteamento IPv6 com IS-IS
-
RFC 5340, OSPF para IPv6 (o RFC 2740 está obsoleto pelo RFC 5340)
-
RFC 5575, Disseminação de Regras de Especificação de Fluxo
-
RFC 5798, protocolo de redundância de roteador virtual (VRRP) versão 3 para IPv4 e IPv6
-
RFC 5905, Network Time Protocol versão 4 (para IPv6)
-
RFC 5952, uma recomendação para representação de texto de endereço IPv6
-
RFC 6164, usando prefixos IPv6 de 127 bits em links entre roteadores
-
RFC 6527, Definições de Objetos Gerenciados para o Protocolo de Redundância de Roteador Virtual Versão 3 (VRRPv3)
Os seguintes recursos não são suportados:
-
Criação de linha
-
SetOperação -
vrrpv3StatisticsPacketLengthErrorsObjeto MIB -
vrrpv3StatisticsRowDiscontinuityTimeObjeto MIB
-
-
RFC 6583, problemas operacionais de descoberta de vizinhos
Há suporte apenas para priorizar atividades do NDP, ajustar o limite de taxa da fila do NDP e ajustar a fila.
-
RFC 6724, seleção de endereço padrão para o protocolo de Internet versão 6 (IPv6)
-
Especificação RFC 8200 , Protocolo de Internet, versão 6 (IPv6)
-
RFC 8201, descoberta de MTU de caminho para IP versão 6
-
RFC 8335, PROBE: um utilitário para sondagem de interfaces
-
RFC 8415, protocolo de configuração dinâmica de host para IPv6 (DHCPv6)
-
draft-ietf-l3vpn-bgp-ipv6-07.txt de rascunho da Internet, extensão VPN IP BGP-MPLS para VPN IPv6
-
draft-ietf-lsr-flex-algo-20.txt de rascunho da Internet, IGP algoritmo flexível para permitir que os IGPs calculem caminhos baseados em restrições na rede.
-
Rascunho de draft-ietf-idr-flow-spec-00.txt na Internet, Disseminação de regras de especificação de fluxo
-
Rascunho da Internet draft-ietf-softwire-dual-stack-lite-04.txt, implantações de banda larga Dual-Stack Lite após o esgotamento do IPv4
-
draft-kato-bgp-ipv6-link-local-00.txt de rascunho da Internet, peering BGP4+ usando endereço local de link IPv6
Os RFCs e o rascunho da Internet a seguir não definem padrões, mas fornecem informações sobre o IPv6 e tecnologias relacionadas. O IETF os classifica como "Experimentais" ou "Informativos".
-
RFC 1901, introdução ao SNMPv2 baseado na comunidade
-
RFC 2081, declaração de aplicabilidade do protocolo RIPng
-
RFC 2767, hosts de pilha dupla usando a técnica de "colisão-na-pilha" (BIS)
-
RFC 3587, formato de endereço unicast global IPv6
-
Rascunho da Internet draft-ietf-ngtrans-bgp-túnel-04.txt, Conectando ilhas IPv6 em nuvens IPv4 com BGP
Somente a abordagem MP-BGP sobre IP versão 4 (IPv4) é suportada.